summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-01-29 00:02:53 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-01-29 00:03:22 +0100
commit19948b6f0211355afbb0370ce562719b92e09e32 (patch)
tree3b569223e1edc3d1f373d489453a86dbb621f55a
parentx11-misc/sct: new package. (diff)
downloadgentoo-19948b6f0211355afbb0370ce562719b92e09e32.tar.gz
gentoo-19948b6f0211355afbb0370ce562719b92e09e32.tar.bz2
gentoo-19948b6f0211355afbb0370ce562719b92e09e32.zip
net-print/cups-pdf: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--net-print/cups-pdf/Manifest1
-rw-r--r--net-print/cups-pdf/cups-pdf-3.0.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-print/cups-pdf/Manifest b/net-print/cups-pdf/Manifest
index 901da974674b..a91a48f79668 100644
--- a/net-print/cups-pdf/Manifest
+++ b/net-print/cups-pdf/Manifest
@@ -1,2 +1,3 @@
DIST cups-pdf_2.6.1.tar.gz 33315 SHA256 04e17eb563dceea048e1a435edcbcf52faa5288f85e8390cd64d702edb6745f1 SHA512 60702159907f95e005c93a38551b5aaa65b7e4b8e009b48becf4523d606c4bbb127e81e5acf8519ce4c9aed90b41deb01d80171f3145086351dbd022863a3816 WHIRLPOOL dec796386df1b13c6fa8cfaed71cf9442a0aa8fc8ba739f8aa8ac3f2fc1e0ec3a1cbd205835f6f10314b805b0744641f3788458863df63104373bbf11e64e886
+DIST cups-pdf_3.0.0.tar.gz 29654 SHA256 a0b94d09ccf92761a83e1af13fcdbfba737d7fcbbe2774ec24297ddbbf13aebe SHA512 14420e50b9ac93d12e75b98ba8c3456d35a3bcce0778eee8308ac7a3c3a987b4dca5a4f140353bd2060a5f0f4d3434c442b00ea309660b4e5a72fe11dba25276 WHIRLPOOL f95b21be0db15e2aa6af8d769a5d8efcf4447c3b69a2e7128f6ba51ce6e8c575aec78c69ef97ad8b6e7cc69c6a10635acf52b81ba0e415b553e99bef5675864e
DIST cups-pdf_3.0beta1.tar.gz 38040 SHA256 d8f30740e0092e7b53cd228d9ddae8085bde744b5e63064bf79ad0c3e3ebe578 SHA512 89d77bf8daa4f82cde4db32c607a5d503ae37bc720906b9fafbd7dedac3cb522fbc342475cf4cff62fdbb16c59c7a1a62814cf85492f6a97e277e64c886985f5 WHIRLPOOL 6d44d4c62f198a4b8da83791bb22bad9e3a43dbcad2a587729e41eb80cd9a5cb14561dff522c6452cb591ad6463b14d9d0ff41b19e7c58db494db421d2446bf6
diff --git a/net-print/cups-pdf/cups-pdf-3.0.0.ebuild b/net-print/cups-pdf/cups-pdf-3.0.0.ebuild
new file mode 100644
index 000000000000..7bed03e6b62e
--- /dev/null
+++ b/net-print/cups-pdf/cups-pdf-3.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files"
+HOMEPAGE="http://www.cups-pdf.de/"
+SRC_URI="http://www.cups-pdf.de/src/${PN}_${PV/_}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="+ppds"
+
+RDEPEND="
+ net-print/cups
+ app-text/ghostscript-gpl
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${PV/_}
+
+src_compile() {
+ pushd src >/dev/null
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} ${PN}.c -o ${PN} -lcups || die
+ popd >/dev/null
+}
+
+src_install() {
+ exeinto /usr/libexec/cups/backend
+ exeopts -m0700
+ doexe src/cups-pdf
+
+ insinto /etc/cups
+ doins extra/cups-pdf.conf
+
+ insinto /usr/share/cups/model
+ if use ppds; then
+ doins extra/CUPS-PDF_opt.ppd
+ else
+ doins extra/CUPS-PDF_noopt.ppd
+ fi
+
+ dodoc ChangeLog README
+}