summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2016-09-27 23:27:24 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-11 09:48:46 +0200
commit0b9f32f0c6e8816d8b0e9b2ff6d5bb96cbf2190c (patch)
treee4c4a1dd735ddda685330db5562243e63b0ad0ff
parentlicenses: new license used by openfortivpn (diff)
downloadgentoo-0b9f32f0c6e8816d8b0e9b2ff6d5bb96cbf2190c.tar.gz
gentoo-0b9f32f0c6e8816d8b0e9b2ff6d5bb96cbf2190c.tar.bz2
gentoo-0b9f32f0c6e8816d8b0e9b2ff6d5bb96cbf2190c.zip
net-misc/openfortivpn: New package
openfortivpn is a client for PPP+SSL VPN tunnel services. It spawns a pppd process and operates the communication between the gateway and this process. It is compatible with Fortinet VPNs. Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2424 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-misc/openfortivpn/Manifest1
-rw-r--r--net-misc/openfortivpn/metadata.xml12
-rw-r--r--net-misc/openfortivpn/openfortivpn-1.2.0.ebuild38
3 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/openfortivpn/Manifest b/net-misc/openfortivpn/Manifest
new file mode 100644
index 000000000000..f8b63843af46
--- /dev/null
+++ b/net-misc/openfortivpn/Manifest
@@ -0,0 +1 @@
+DIST openfortivpn-1.2.0.tar.gz 44609 SHA256 2e0592eb053686f7f54eabf2fd2252446074e6d11072413f98ba5ff07d8c68ab SHA512 836ba43a156c2575222b5d553005662c5a44ad4e21c1a8dc9896d117a1dac2dce64a6815e9b05cb921c2f6166b003c83885e07a8d50a9aca9c5f3cc68f229a67 WHIRLPOOL 8874e0b9d6d103fda8446d75cc9789480b5adfdd3bc734867ae9e6e7518632460f8d609b95df8eedc26d602320c4c3218d223c33c502faed2a7620cda9a23ea0
diff --git a/net-misc/openfortivpn/metadata.xml b/net-misc/openfortivpn/metadata.xml
new file mode 100644
index 000000000000..b7fa921dff8f
--- /dev/null
+++ b/net-misc/openfortivpn/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mathy@vanvoorden.be</email>
+ <name>Mathy Vanvoorden</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/openfortivpn/openfortivpn-1.2.0.ebuild b/net-misc/openfortivpn/openfortivpn-1.2.0.ebuild
new file mode 100644
index 000000000000..ed1be00c80c4
--- /dev/null
+++ b/net-misc/openfortivpn/openfortivpn-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools linux-info
+
+DESCRIPTION="A Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}