summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-04 18:21:01 -0500
committerTim Harder <radhermit@gentoo.org>2017-10-04 18:23:03 -0500
commit02e1d32778be622a7069154af6669107756c540b (patch)
tree71e2632f11640620a41021dcad814fdd96a53045
parentdev-libs/liblognorm: Bump to v2.0.4 (diff)
downloadgentoo-02e1d32778be622a7069154af6669107756c540b.tar.gz
gentoo-02e1d32778be622a7069154af6669107756c540b.tar.bz2
gentoo-02e1d32778be622a7069154af6669107756c540b.zip
dev-python/snakeoil: remove old
-rw-r--r--dev-python/snakeoil/Manifest2
-rw-r--r--dev-python/snakeoil/files/snakeoil-0.7.1-test.patch31
-rw-r--r--dev-python/snakeoil/snakeoil-0.7.1.ebuild36
-rw-r--r--dev-python/snakeoil/snakeoil-0.7.3.ebuild35
4 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index d964b0cc7f6e..4e79c6a54b5b 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1,3 +1 @@
-DIST snakeoil-0.7.1.tar.gz 214261 SHA256 e210db2713da8431eea6b6b3afc98bea829c6612733e6309871b2614d08dcc5b SHA512 1c0d03d50a1738cbb3cceecec9445585d089ea535657467871930cca7282d3426780451fb45774e16b05714a1da13766d68f62def7a2d957e2124bd71335d0a0 WHIRLPOOL aa20cabbceaae564802b8ed5a7a6e5dc1039d27021d477179bcad28d4317b875cbddb889e7196fc1c091a802dd28f8c7efe1c6680b170a54c5e2b07c23052623
-DIST snakeoil-0.7.3.tar.gz 301229 SHA256 c51ba2e3e6f59b7988afd9ad49bf37e9b155fe4a54da3fa11fc728e02ebf5ea3 SHA512 a3b303a6b5da9e12b2eef8ffbd86bae173ef5cd8c2c2d36e818af8c228519fa44bf79c7f8122cc5e3c555f47e904dc766ceb8393dbef6f2edd9a218c7080b95e WHIRLPOOL 988c3a9eb07e251908628f4c899827b868432979759fd8a935386ed843f89cca855f1262cd88b8ba5aa1a0ad088e3942ec94d818282d086036ac03add58c0e23
DIST snakeoil-0.7.4.tar.gz 301878 SHA256 67280c86e4b02c34100603d7525270c0017e0d182df54ad31ec2e5c145e69ceb SHA512 b3ae2223a267fa74699664470a4c4f6888cf2b68e688fe61d3acca85e00a138c3a037482ef304ee26f326cba252b473d265dcd72d0e0ab5723f4b0ed6e5e04ce WHIRLPOOL c76905b7540ad1ab2186d2ce9a75a55660eb343a1cfefc835f8012f3cf10ad706ee837a995085fa327f38de8f790cc2155c540e5b0d2a6f90a0aebbf7198c7bb
diff --git a/dev-python/snakeoil/files/snakeoil-0.7.1-test.patch b/dev-python/snakeoil/files/snakeoil-0.7.1-test.patch
deleted file mode 100644
index 73e2701b0eb2..000000000000
--- a/dev-python/snakeoil/files/snakeoil-0.7.1-test.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 8ee72903bc714725fbcfdcc38b9228772758b890 Mon Sep 17 00:00:00 2001
-From: Tim Harder <radhermit@gmail.com>
-Date: Fri, 27 Jan 2017 11:54:39 -0500
-Subject: [PATCH] test: fix delayed instantiation tests for py3.6
-
----
- snakeoil/test/test_obj.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/snakeoil/test/test_obj.py b/snakeoil/test/test_obj.py
-index abcad55..f8aafd2 100644
---- a/snakeoil/test/test_obj.py
-+++ b/snakeoil/test/test_obj.py
-@@ -29,7 +29,7 @@ def test_simple(self):
-
- def test_descriptor_awareness(self):
- def assertKls(cls, ignores=(),
-- default_ignores=("__new__", "__init__",
-+ default_ignores=("__new__", "__init__", "__init_subclass__",
- "__getattribute__", "__class__",
- "__getnewargs__", "__doc__")):
- required = set(x for x in dir(cls)
-@@ -53,7 +53,7 @@ def test_BaseDelayedObject(self):
- # assert that all methods/descriptors of object
- # are covered via the base.
- o = set(dir(object)).difference("__%s__" % x for x in [
-- "class", "getattribute", "new", "init", "doc"])
-+ "class", "getattribute", "new", "init", "init_subclass", "doc"])
- diff = o.difference(obj.base_kls_descriptors)
- self.assertFalse(diff, msg=(
- "base delayed instantiation class should cover all of object, but "
diff --git a/dev-python/snakeoil/snakeoil-0.7.1.ebuild b/dev-python/snakeoil/snakeoil-0.7.1.ebuild
deleted file mode 100644
index 080b0c89c380..000000000000
--- a/dev-python/snakeoil/snakeoil-0.7.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
- inherit git-r3
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
- SRC_URI="https://github.com/pkgcore/${PN}/releases/download/v${PV}/${P}.tar.gz"
-fi
-
-DESCRIPTION="misc common functionality and useful optimizations"
-HOMEPAGE="https://github.com/pkgcore/snakeoil"
-
-LICENSE="BSD"
-SLOT="0"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/${P}-test.patch"
-)
-
-python_configure_all() {
- # disable snakeoil 2to3 caching
- unset PY2TO3_CACHEDIR
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/snakeoil/snakeoil-0.7.3.ebuild b/dev-python/snakeoil/snakeoil-0.7.3.ebuild
deleted file mode 100644
index c037456a6ebe..000000000000
--- a/dev-python/snakeoil/snakeoil-0.7.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
- inherit git-r3
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="misc common functionality and useful optimizations"
-HOMEPAGE="https://github.com/pkgcore/snakeoil"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-[[ ${PV} == 9999 ]] && DEPEND+=" $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python3*')"
-
-python_configure_all() {
- # disable snakeoil 2to3 caching
- unset PY2TO3_CACHEDIR
-}
-
-python_test() {
- esetup.py test
-}