summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-07 06:37:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-07 08:06:33 +0100
commit01676b196c5041018b9752b9c74587c17288bc6c (patch)
treeadd4d85f61162f3774cd0520fab92bc43570fa82
parentdev-python/chameleon: Bump to 4.0.0 (diff)
downloadgentoo-01676b196c5041018b9752b9c74587c17288bc6c.tar.gz
gentoo-01676b196c5041018b9752b9c74587c17288bc6c.tar.bz2
gentoo-01676b196c5041018b9752b9c74587c17288bc6c.zip
dev-python/django-otp: Bump to 1.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-1.1.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 8693fc39866f..1e28fcd30796 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1 +1,2 @@
DIST django-otp-1.1.4.gh.tar.gz 75551 BLAKE2B 95f1e181542f595c5ce4059e037d47720899eac566af5d93414a64829bccbd054096bcbe1b5624e975483e45fccc88f62888c21fbb630e533be1eed9be1c0d84 SHA512 6bf6fbb6fe274bb8cd5de1ae31fad2bcb019332d3b10faffcffcd1f68a1160dffc2093eaadfd684c91372522e0132198df00da9e8cd0249124fd7020d63b91c3
+DIST django-otp-1.1.5.gh.tar.gz 75725 BLAKE2B 8277166593be01db71dfdf3184b602d6224a411522b63b115211232473823fb811ae9a827c29245b105f1c88ea2b91ec823dfa9f7aa7a9badace33fb6e8efd50 SHA512 ab762ae6272fc1ff174bb923bc6196bc6f7cdfc2c0c022015302bd3be31a1b171800310bbb1fde5e109ac73a827f06ab4e3aae32f47bb5a494e22c0f620dd339
diff --git a/dev-python/django-otp/django-otp-1.1.5.ebuild b/dev-python/django-otp/django-otp-1.1.5.ebuild
new file mode 100644
index 000000000000..f06aca9ee006
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.1.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="
+ https://github.com/django-otp/django-otp/
+ https://pypi.org/project/django-otp/
+"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ "${EPYTHON}" -m django test -v 2 django_otp ||
+ die "Tests fail with ${EPYTHON}"
+}