summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2021-01-27 22:59:49 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2021-01-27 22:59:49 -0100
commit97e2a2c987e8db3894b44256f8bd8bc1c80e46b3 (patch)
tree622e85e0eadb2a983bf30d17d7f30feb3384b0b2 /net-misc/anydesk/anydesk-6.0.1.ebuild
parentwww-apps/drupal: Drop vulnerable releases. (diff)
downloadjmbsvicetto-97e2a2c987e8db3894b44256f8bd8bc1c80e46b3.tar.gz
jmbsvicetto-97e2a2c987e8db3894b44256f8bd8bc1c80e46b3.tar.bz2
jmbsvicetto-97e2a2c987e8db3894b44256f8bd8bc1c80e46b3.zip
net-misc/anydesk: Sync from tree.
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'net-misc/anydesk/anydesk-6.0.1.ebuild')
-rw-r--r--net-misc/anydesk/anydesk-6.0.1.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/net-misc/anydesk/anydesk-6.0.1.ebuild b/net-misc/anydesk/anydesk-6.0.1.ebuild
index 6b1d45e..ba96ed3 100644
--- a/net-misc/anydesk/anydesk-6.0.1.ebuild
+++ b/net-misc/anydesk/anydesk-6.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit desktop eutils systemd xdg-utils
+inherit desktop optfeature systemd xdg-utils
DESCRIPTION="Feature rich multi-platform remote desktop application"
HOMEPAGE="https://anydesk.com"
@@ -48,8 +48,8 @@ RDEPEND="
x11-libs/libXt
x11-libs/libXtst
x11-libs/pango
- x11-libs/pangox-compat
"
+BDEPEND="dev-util/patchelf"
RESTRICT="bindist mirror"
@@ -58,15 +58,17 @@ QA_PREBUILT="opt/${PN}/*"
src_install() {
local dst="/opt/${PN}"
- dodir ${dst}
exeinto ${dst}
doexe ${PN}
+ # bug 706344
+ patchelf --remove-needed libpangox-1.0.so.0 "${ED}${dst}/${PN}" || die
+
dodir /opt/bin
- dosym ${dst}/${PN} /opt/bin/${PN}
+ dosym "${dst}/${PN}" "/opt/bin/${PN}"
- newinitd "${FILESDIR}"/anydesk.init anydesk
- systemd_newunit "${FILESDIR}"/anydesk-4.0.1.service anydesk.service
+ newinitd "${FILESDIR}/anydesk.init" anydesk
+ systemd_newunit "${FILESDIR}/anydesk-4.0.1.service" anydesk.service
insinto /usr/share/polkit-1/actions
doins polkit-1/com.philandro.anydesk.policy
@@ -74,9 +76,9 @@ src_install() {
insinto /usr/share
doins -r icons
- domenu "${FILESDIR}"/anydesk.desktop
+ domenu "${FILESDIR}/anydesk.desktop"
- keepdir /etc/${PN}
+ keepdir "/etc/${PN}"
dodoc copyright README
}