summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2015-07-01 17:21:12 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2015-07-01 17:21:12 +0000
commitee4f7cddbd87d561307eb64db84df12956701004 (patch)
treef24618dd321e601e55853d567681afa247431db2 /app-misc
parentBump drupal to releases 7.38 and 6.36 - fixes bug 552416. (diff)
downloadjmbsvicetto-ee4f7cddbd87d561307eb64db84df12956701004.tar.gz
jmbsvicetto-ee4f7cddbd87d561307eb64db84df12956701004.tar.bz2
jmbsvicetto-ee4f7cddbd87d561307eb64db84df12956701004.zip
Drop depend.php from inherit - fixes bug 552858.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gramps/Manifest2
-rw-r--r--app-misc/gramps/files/gramps-resourcepath.patch11
-rw-r--r--app-misc/gramps/files/gramps-use_bsddb3.patch11
-rw-r--r--app-misc/gramps/gramps-3.4.9.ebuild78
-rw-r--r--app-misc/gramps/gramps-4.1.3.ebuild51
5 files changed, 153 insertions, 0 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
new file mode 100644
index 0000000..fa39b9f
--- /dev/null
+++ b/app-misc/gramps/Manifest
@@ -0,0 +1,2 @@
+DIST gramps-3.4.9.tar.gz 10190446 SHA256 402a8616efeda730d10941690edb6dfb2719c3f7383e376a404577412676a8f3 SHA512 f15481b3791a98568a0a7f734ef5eb9a1149cf76c5e83f1270eee41bcf3518713391cb271a54177e6e6bbaf78da098d7a7a2a807266c971c1331dbb9d29d5fbb WHIRLPOOL 834777cb20ee7a3ef7a2397eef5a0e70caab02666cf127ba01f6310ac68463ea67733883cd3ca63676b9541dc104da818986d7b249950ae6a30415f5fa1bddee
+DIST gramps-4.1.3.tar.gz 17244017 SHA256 25501a01419c9a13e70574c57543e7bbac5d3b59760fac8027196a39e029fe8e SHA512 f52210f5e15ef3435d503f6b96b5a3960a4c6a4e3358d981514a2880801efdd6623eaed8237e5d9a08c26608670f6649967bb0e18500c480541d1e4866d668a8 WHIRLPOOL 08612469fd974aa304d47474c0127c3f660606261f2f3f682745bf46a0845242080bf454b2f77b5eb47985c80e1ffa5c0ad75cd97f0d3679515d015bac1e36a5
diff --git a/app-misc/gramps/files/gramps-resourcepath.patch b/app-misc/gramps/files/gramps-resourcepath.patch
new file mode 100644
index 0000000..b414e94
--- /dev/null
+++ b/app-misc/gramps/files/gramps-resourcepath.patch
@@ -0,0 +1,11 @@
+--- setup.py.old 2014-04-11 14:37:05.557343225 -0400
++++ setup.py 2014-04-11 14:37:30.560989056 -0400
+@@ -248,7 +248,7 @@
+ 'utils', 'resource-path')
+ with io.open(resource_file, 'w', encoding='utf-8',
+ errors='strict') as fp:
+- path = os.path.abspath(os.path.join(self.install_data, 'share'))
++ path = '/usr/share'
+ if sys.version_info[0] < 3:
+ path = unicode(path)
+ fp.write(path)
diff --git a/app-misc/gramps/files/gramps-use_bsddb3.patch b/app-misc/gramps/files/gramps-use_bsddb3.patch
new file mode 100644
index 0000000..930f408
--- /dev/null
+++ b/app-misc/gramps/files/gramps-use_bsddb3.patch
@@ -0,0 +1,11 @@
+--- gramps-4.1.1/gramps/gen/config.py.orig 2015-02-23 13:20:20.150291498 -0500
++++ gramps-4.1.1/gramps/gen/config.py 2015-02-23 13:20:37.260291400 -0500
+@@ -313,7 +313,7 @@
+ register('preferences.use-last-view', False)
+ register('preferences.last-view', '')
+ register('preferences.last-views', [])
+-register('preferences.use-bsddb3', False)
++register('preferences.use-bsddb3', True)
+ register('preferences.family-relation-type', 3) # UNKNOWN
+ register('preferences.age-display-precision', 1)
+ register('preferences.color-gender-male-alive', '#b8cee6')
diff --git a/app-misc/gramps/gramps-3.4.9.ebuild b/app-misc/gramps/gramps-3.4.9.ebuild
new file mode 100644
index 0000000..b5ee8a4
--- /dev/null
+++ b/app-misc/gramps/gramps-3.4.9.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="Genealogical Research and Analysis Management Programming System"
+HOMEPAGE="http://www.gramps-project.org/"
+SRC_URI="mirror://sourceforge/gramps/Stable/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="gnome reports spell webkit"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ dev-python/pygoocanvas[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.16.0[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2
+ sci-geosciences/osm-gps-map
+ x11-misc/xdg-utils
+ gnome? (
+ dev-python/gconf-python[${PYTHON_USEDEP}]
+ dev-python/libgnome-python[${PYTHON_USEDEP}]
+ )
+ spell? ( dev-python/gtkspell-python[${PYTHON_USEDEP}] )
+ reports? ( media-gfx/graphviz )
+ webkit? ( dev-python/pywebkitgtk[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/libiconv
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.4.0-use_bsddb3.patch"
+
+ # Fix install path, bug 423315 for example
+ einfo "Fix installation path"
+ find . -iname 'Makefile.in' | xargs \
+ sed "s;\(pkgdatadir = \)\(\$(datadir)\);\1$(python_get_sitedir);" -i \
+ || die
+ find . -iname 'Makefile.in' | xargs \
+ sed "s;\(pkgpythondir = \)\(\$(datadir)\);\1$(python_get_sitedir);" -i \
+ || die
+
+ sed "s;\$(prefix)/share/gramps;/$(python_get_sitedir)/@PACKAGE@;" \
+ -i src/Makefile.in || die
+
+ sed "s;\$(prefix)/share/gramps;/$(python_get_sitedir)/@PACKAGE@;" \
+ -i src/docgen/Makefile.in || die
+
+ einfo "Fix wrapper script"
+ sed "s;@datadir@;$(python_get_sitedir);" \
+ -i gramps.sh.in || die
+
+ einfo "Fix icon location"
+ sed "s;gramps/;pixmap/;g" -i data/gramps.keys.in || die
+
+ python_fix_shebang .
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-mime-install \
+ PYTHON="${EROOT}"/usr/bin/python2
+}
diff --git a/app-misc/gramps/gramps-4.1.3.ebuild b/app-misc/gramps/gramps-4.1.3.ebuild
new file mode 100644
index 0000000..6e5670e
--- /dev/null
+++ b/app-misc/gramps/gramps-4.1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+#DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Genealogical Research and Analysis Management Programming System"
+HOMEPAGE="http://www.gramps.org/"
+SRC_URI="mirror://sourceforge/gramps/Stable/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geography +gexiv2 html +reports spell"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/bsddb3
+ >=dev-python/pygobject-3.2.2-r1:3[${PYTHON_USEDEP}]
+ dev-python/pyicu
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/pango[introspection]
+ x11-misc/xdg-utils
+ geography? ( >=sci-geosciences/osm-gps-map-1.0 )
+ gexiv2? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
+ html? ( net-libs/webkit-gtk:3[introspection]
+ reports? ( media-gfx/graphviz )
+ spell? (
+ dev-python/gtkspell-python
+ app-text/gtkspell[introspection]
+ )
+)"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+DOCS="RELEASE_NOTES FAQ AUTHORS TODO NEWS README ChangeLog"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-resourcepath.patch"
+# epatch "${FILESDIR}/${P}-python-doc-init.patch"
+# epatch "${FILESDIR}/${P}-print-guiplug-error.patch"
+ epatch "${FILESDIR}/${PN}-use_bsddb3.patch"
+ distutils-r1_src_prepare
+}