summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSven Schwyn <gentoo@bitcetera.com>2008-07-30 09:15:07 +0000
committerSven Schwyn <gentoo@bitcetera.com>2008-07-30 09:15:07 +0000
commit4e3c7450663ad9a0de493e6945088ae6c3f276c1 (patch)
tree28845335175d5bb388c62adf0298a2431d0d425a /net-im
parentnet-misc/asterisk-1.4: version bump. fixing security issues 232696 and 232698 . (diff)
downloadvoip-4e3c7450663ad9a0de493e6945088ae6c3f276c1.tar.gz
voip-4e3c7450663ad9a0de493e6945088ae6c3f276c1.tar.bz2
voip-4e3c7450663ad9a0de493e6945088ae6c3f276c1.zip
New ebuild net-im/ihu (bug 133967)
svn path=/trunk/; revision=705
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ihu/ChangeLog7
-rw-r--r--net-im/ihu/ihu-0.6.0.ebuild34
2 files changed, 41 insertions, 0 deletions
diff --git a/net-im/ihu/ChangeLog b/net-im/ihu/ChangeLog
new file mode 100644
index 0000000..be26574
--- /dev/null
+++ b/net-im/ihu/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-im/ihu
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 29 Jul 2008; Sven Schwyn (svoop) <gentoo@bitcetera.com>
+ +ihu-0.6.0.ebuild:
+ initial version, thanks to Sok Ann Yap
diff --git a/net-im/ihu/ihu-0.6.0.ebuild b/net-im/ihu/ihu-0.6.0.ebuild
new file mode 100644
index 0000000..d4f243a
--- /dev/null
+++ b/net-im/ihu/ihu-0.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils qt3
+
+DESCRIPTION="Peer-to-Peer VoIP Application"
+HOMEPAGE="http://ihu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ihu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="jack"
+
+DEPEND="$(qt_min_version 3.2)
+ media-libs/libsoundtouch
+ media-libs/speex
+ media-libs/libogg
+ media-libs/alsa-lib
+ jack? ( media-sound/jack-audio-connection-kit )"
+
+src_compile() {
+ econf \
+ --with-Qt-dir=${QTDIR} \
+ `use_enable jack` \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ make_desktop_entry ihu "I Hear U" "/usr/share/doc/ihu/ihubig.png" "Network;Telephony;Qt"
+}