summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-10-23 20:26:36 -0400
committerMike Frysinger <vapier@gentoo.org>2014-10-23 20:26:36 -0400
commit0e86502e817e1b338a7841076e3f9f799cc3123a (patch)
tree9867289559a5b5170e2d913e5fdf2cae64777ac6
parentgcc: use DESCRIPTION/LICENSE from the eclass (diff)
downloadtoolchain-0e86502e817e1b338a7841076e3f9f799cc3123a.tar.gz
toolchain-0e86502e817e1b338a7841076e3f9f799cc3123a.tar.bz2
toolchain-0e86502e817e1b338a7841076e3f9f799cc3123a.zip
drop GCC_SPEC env support from older versions
-rw-r--r--sys-devel/gcc/files/gcc-spec-env.patch42
-rw-r--r--sys-devel/gcc/gcc-4.0.2-r3.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.0.3.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.1.0-r1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.1.1-r3.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.2.0.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.2.1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.2.2.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.2.3.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.3.0.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.3.1-r1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.3.2-r4.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.3.3-r2.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.3.4.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.3.5.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.4.0-r1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.4.1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.4.2.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.4.3-r3.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.4.4-r2.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.4.5.ebuild1
-rw-r--r--sys-devel/gcc/gcc-4.4.6-r1.ebuild1
-rw-r--r--sys-devel/gcc/gcc-4.5.0.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.6.0_alpha20130405.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140405.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140412.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140419.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140426.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140503.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140510.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140517.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140524.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140531.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.7.0_alpha20140607.ebuild3
34 files changed, 0 insertions, 117 deletions
diff --git a/sys-devel/gcc/files/gcc-spec-env.patch b/sys-devel/gcc/files/gcc-spec-env.patch
deleted file mode 100644
index 57e7567..0000000
--- a/sys-devel/gcc/files/gcc-spec-env.patch
+++ /dev/null
@@ -1,42 +0,0 @@
- Add support for external spec file via the GCC_SPECS env var. This
- allows us to easily control pie/ssp defaults with gcc-config profiles.
-
- Original patch by Rob Holland
- Extended to support multiple entries separated by ':' by Kevin F. Quinn
- Modified to use getenv instead of poisoned GET_ENVIRONMENT by Ryan Hill
-
---- gcc-4/gcc/gcc.c
-+++ gcc-4/gcc/gcc.c
-@@ -6482,6 +6482,32 @@
-
- /* Process any user specified specs in the order given on the command
- line. */
-+#if !(defined (__MSDOS__) || defined (OS2) || defined (VMS) || defined (WIN32))
-+ /* Add specs listed in GCC_SPECS. Note; in the process of separating
-+ * each spec listed, the string is overwritten at token boundaries
-+ * (':') with '\0', an effect of strtok_r().
-+ */
-+ specs_file = getenv ("GCC_SPECS");
-+ if (specs_file && (strlen(specs_file) > 0))
-+ {
-+ char *spec, *saveptr;
-+ for (spec=strtok_r(specs_file,":",&saveptr);
-+ spec!=NULL;
-+ spec=strtok_r(NULL,":",&saveptr))
-+ {
-+ struct user_specs *user = (struct user_specs *)
-+ xmalloc (sizeof (struct user_specs));
-+
-+ user->next = (struct user_specs *) 0;
-+ user->filename = spec;
-+ if (user_specs_tail)
-+ user_specs_tail->next = user;
-+ else
-+ user_specs_head = user;
-+ user_specs_tail = user;
-+ }
-+ }
-+#endif
- for (uptr = user_specs_head; uptr; uptr = uptr->next)
- {
- char *filename = find_a_file (&startfile_prefixes, uptr->filename,
diff --git a/sys-devel/gcc/gcc-4.0.2-r3.ebuild b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
index 5586a5e..000dae2 100644
--- a/sys-devel/gcc/gcc-4.0.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
@@ -21,8 +21,6 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
# Fix cross-compiling
epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-cross-compile.patch
diff --git a/sys-devel/gcc/gcc-4.0.3.ebuild b/sys-devel/gcc/gcc-4.0.3.ebuild
index 3372484..84a6219 100644
--- a/sys-devel/gcc/gcc-4.0.3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.3.ebuild
@@ -19,8 +19,6 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
# Fix cross-compiling
epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-cross-compile.patch
diff --git a/sys-devel/gcc/gcc-4.1.0-r1.ebuild b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
index ed98c4f..efdcbdd 100644
--- a/sys-devel/gcc/gcc-4.1.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
@@ -18,8 +18,6 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
# Fix cross-compiling
epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
diff --git a/sys-devel/gcc/gcc-4.1.1-r3.ebuild b/sys-devel/gcc/gcc-4.1.1-r3.ebuild
index 2e33185..f07b144 100644
--- a/sys-devel/gcc/gcc-4.1.1-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.1.1-r3.ebuild
@@ -20,8 +20,6 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
# Fix cross-compiling
epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
diff --git a/sys-devel/gcc/gcc-4.2.0.ebuild b/sys-devel/gcc/gcc-4.2.0.ebuild
index d411297..92574aa 100644
--- a/sys-devel/gcc/gcc-4.2.0.ebuild
+++ b/sys-devel/gcc/gcc-4.2.0.ebuild
@@ -20,7 +20,5 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.2.1.ebuild b/sys-devel/gcc/gcc-4.2.1.ebuild
index 79116e3..bb3b226 100644
--- a/sys-devel/gcc/gcc-4.2.1.ebuild
+++ b/sys-devel/gcc/gcc-4.2.1.ebuild
@@ -20,7 +20,5 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.2.2.ebuild b/sys-devel/gcc/gcc-4.2.2.ebuild
index 2f0030b..03dc6b2 100644
--- a/sys-devel/gcc/gcc-4.2.2.ebuild
+++ b/sys-devel/gcc/gcc-4.2.2.ebuild
@@ -20,7 +20,5 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.2.3.ebuild b/sys-devel/gcc/gcc-4.2.3.ebuild
index af688eb..1098129 100644
--- a/sys-devel/gcc/gcc-4.2.3.ebuild
+++ b/sys-devel/gcc/gcc-4.2.3.ebuild
@@ -20,7 +20,5 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.3.0.ebuild b/sys-devel/gcc/gcc-4.3.0.ebuild
index f280784..dcfdbee 100644
--- a/sys-devel/gcc/gcc-4.3.0.ebuild
+++ b/sys-devel/gcc/gcc-4.3.0.ebuild
@@ -20,7 +20,5 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.3.1-r1.ebuild b/sys-devel/gcc/gcc-4.3.1-r1.ebuild
index a07b2eb..ba51dcb 100644
--- a/sys-devel/gcc/gcc-4.3.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.3.1-r1.ebuild
@@ -21,7 +21,5 @@ src_unpack() {
use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.3.2-r4.ebuild b/sys-devel/gcc/gcc-4.3.2-r4.ebuild
index 2eacfe2..3a2064d 100644
--- a/sys-devel/gcc/gcc-4.3.2-r4.ebuild
+++ b/sys-devel/gcc/gcc-4.3.2-r4.ebuild
@@ -38,7 +38,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.3.2/gcc-4.3.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.3.3-r2.ebuild b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
index e720f02..5f81849 100644
--- a/sys-devel/gcc/gcc-4.3.3-r2.ebuild
+++ b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
@@ -37,7 +37,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.3.2/gcc-4.3.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.3.4.ebuild b/sys-devel/gcc/gcc-4.3.4.ebuild
index 1611c77..8203fc7 100644
--- a/sys-devel/gcc/gcc-4.3.4.ebuild
+++ b/sys-devel/gcc/gcc-4.3.4.ebuild
@@ -37,7 +37,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.3.2/gcc-4.3.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.3.5.ebuild b/sys-devel/gcc/gcc-4.3.5.ebuild
index 4568682..d617f66 100644
--- a/sys-devel/gcc/gcc-4.3.5.ebuild
+++ b/sys-devel/gcc/gcc-4.3.5.ebuild
@@ -37,7 +37,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.3.2/gcc-4.3.2-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.4.0-r1.ebuild b/sys-devel/gcc/gcc-4.4.0-r1.ebuild
index 88247b0..bb53fb2 100644
--- a/sys-devel/gcc/gcc-4.4.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.4.0-r1.ebuild
@@ -36,7 +36,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.4.1.ebuild b/sys-devel/gcc/gcc-4.4.1.ebuild
index a99c79c..5caf64a 100644
--- a/sys-devel/gcc/gcc-4.4.1.ebuild
+++ b/sys-devel/gcc/gcc-4.4.1.ebuild
@@ -37,7 +37,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.4.2.ebuild b/sys-devel/gcc/gcc-4.4.2.ebuild
index 4425677..4f040d3 100644
--- a/sys-devel/gcc/gcc-4.4.2.ebuild
+++ b/sys-devel/gcc/gcc-4.4.2.ebuild
@@ -38,7 +38,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.4.3-r3.ebuild b/sys-devel/gcc/gcc-4.4.3-r3.ebuild
index 3eba014..3ee21c0 100644
--- a/sys-devel/gcc/gcc-4.4.3-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.4.3-r3.ebuild
@@ -39,7 +39,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.4.4-r2.ebuild b/sys-devel/gcc/gcc-4.4.4-r2.ebuild
index 5de54bf..8dd162f 100644
--- a/sys-devel/gcc/gcc-4.4.4-r2.ebuild
+++ b/sys-devel/gcc/gcc-4.4.4-r2.ebuild
@@ -40,7 +40,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.4.5.ebuild b/sys-devel/gcc/gcc-4.4.5.ebuild
index 732d7fb..679d3d6 100644
--- a/sys-devel/gcc/gcc-4.4.5.ebuild
+++ b/sys-devel/gcc/gcc-4.4.5.ebuild
@@ -39,6 +39,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.4.6-r1.ebuild b/sys-devel/gcc/gcc-4.4.6-r1.ebuild
index 1fd09d8..28acc78 100644
--- a/sys-devel/gcc/gcc-4.4.6-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.4.6-r1.ebuild
@@ -39,6 +39,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.5.0.ebuild b/sys-devel/gcc/gcc-4.5.0.ebuild
index b27ed24..d753aef 100644
--- a/sys-devel/gcc/gcc-4.5.0.ebuild
+++ b/sys-devel/gcc/gcc-4.5.0.ebuild
@@ -39,7 +39,5 @@ src_unpack() {
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
}
diff --git a/sys-devel/gcc/gcc-4.6.0_alpha20130405.ebuild b/sys-devel/gcc/gcc-4.6.0_alpha20130405.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.6.0_alpha20130405.ebuild
+++ b/sys-devel/gcc/gcc-4.6.0_alpha20130405.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140405.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140405.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140405.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140405.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140412.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140412.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140412.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140412.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140419.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140419.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140419.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140419.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140426.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140426.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140426.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140426.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140503.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140503.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140503.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140503.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140510.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140510.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140510.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140510.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140517.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140517.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140517.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140517.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140524.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140524.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140524.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140524.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140531.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140531.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140531.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140531.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {
diff --git a/sys-devel/gcc/gcc-4.7.0_alpha20140607.ebuild b/sys-devel/gcc/gcc-4.7.0_alpha20140607.ebuild
index 8b94999..274ad96 100644
--- a/sys-devel/gcc/gcc-4.7.0_alpha20140607.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0_alpha20140607.ebuild
@@ -23,9 +23,6 @@ src_prepare() {
toolchain_src_prepare
use debug && GCC_CHECKS_LIST="yes"
-
- use vanilla && return 0
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env.patch
}
pkg_postinst() {