summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/discount/discount-2.1.3.ebuild')
-rw-r--r--app-text/discount/discount-2.1.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/discount/discount-2.1.3.ebuild b/app-text/discount/discount-2.1.3.ebuild
new file mode 100644
index 000000000..b57126229
--- /dev/null
+++ b/app-text/discount/discount-2.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="An implementation of John Gruber's Markdown text to html language written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="DLPARSONS"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="minimal"
+
+src_prepare() {
+ # for QA, we remove the Makefiles usage of install -s
+ sed -e '/INSTALL_PROGRAM/s#-s ##' -i configure.inc \
+ || die "sed can't fix stripping of files"
+}
+
+src_configure() {
+ local myconf
+ use minimal || myconf="--enable-all-features"
+
+ ./configure.sh "${myconf}" \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+}
+
+src_install() {
+ local myinstall
+ use minimal && myinstall="install" || myinstall="install.everything"
+ emake DESTDIR="${D}" ${myinstall}
+}