summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Matzkov (bapa) <bapabooiee@gmail.com>2011-01-23 20:55:55 +0000
committerDean Matzkov (bapa) <bapabooiee@gmail.com>2011-01-23 20:55:55 +0000
commita2414a43cb1eaaf89c84534e02884e965fd74652 (patch)
tree795faaf81f23cb3c1163d2fb48266bc5b9895ee3 /x11-plugins
parentx11-drivers/libfreenect: New Ebuild for bug 351964 (diff)
downloadsunrise-reviewed-a2414a43cb1eaaf89c84534e02884e965fd74652.tar.gz
sunrise-reviewed-a2414a43cb1eaaf89c84534e02884e965fd74652.tar.bz2
sunrise-reviewed-a2414a43cb1eaaf89c84534e02884e965fd74652.zip
x11-plugins/imgur-integration: New ebuild for bug #352541
svn path=/sunrise/; revision=11725
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/imgur-integration/ChangeLog8
-rw-r--r--x11-plugins/imgur-integration/Manifest4
-rw-r--r--x11-plugins/imgur-integration/imgur-integration-0.3.0.ebuild42
-rw-r--r--x11-plugins/imgur-integration/metadata.xml9
4 files changed, 63 insertions, 0 deletions
diff --git a/x11-plugins/imgur-integration/ChangeLog b/x11-plugins/imgur-integration/ChangeLog
new file mode 100644
index 000000000..842521554
--- /dev/null
+++ b/x11-plugins/imgur-integration/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-plugins/imgur-integration
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 23 Jan 2011; Dean Matzkov (bapa) <bapabooiee@gmail.com>
+ +imgur-integration-0.3.0.ebuild, +metadata.xml:
+ New ebuild for bug #352541
+
diff --git a/x11-plugins/imgur-integration/Manifest b/x11-plugins/imgur-integration/Manifest
new file mode 100644
index 000000000..305f219ac
--- /dev/null
+++ b/x11-plugins/imgur-integration/Manifest
@@ -0,0 +1,4 @@
+DIST imgur-0.3.0.tar.gz 325760 RMD160 0972233aa24daf30d4ba48898511d8c8ca6e736e SHA1 78aa0e476c3800f1a475dc59e776e4be3533c12f SHA256 7a2dc852e2f7deaf917707a37211e57d96444baac871d4aafce507cda9f0c85a
+EBUILD imgur-integration-0.3.0.ebuild 926 RMD160 c266f90c6ce58a727d8dd2ab473b42711042d1de SHA1 6d9b809ceb153c5c0c8fa238916486d12e40b831 SHA256 de0bd6bf9054cad03c766a67888d66ef83ef078e05412f7175eac0a34a850e79
+MISC ChangeLog 268 RMD160 cb57283d2e326ea7f33c0cbe55cffc09298a8772 SHA1 eed1b502a94a6c4fbbf2bd74d95ef7866eb7da2b SHA256 71e59a1faa151ec678e7fe7ab724376149121c5bfd562c0f11cb8fbd47969d0c
+MISC metadata.xml 326 RMD160 7a6135876eac8f27ed2e18f93730abb497a265de SHA1 0cf8ae1a2c268b314231b04024bf749f35fc20dc SHA256 ec91c7cb4f1d8c39711de7a748e6253a881ba195d4c92320fd543d7343ba2e89
diff --git a/x11-plugins/imgur-integration/imgur-integration-0.3.0.ebuild b/x11-plugins/imgur-integration/imgur-integration-0.3.0.ebuild
new file mode 100644
index 000000000..06efed123
--- /dev/null
+++ b/x11-plugins/imgur-integration/imgur-integration-0.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+MY_P=imgur-${PV}
+
+DESCRIPTION="A command-line utility and media-gfx/eog plugin for uploading to imgur.com"
+HOMEPAGE="https://github.com/tthurman/imgur-integration"
+SRC_URI="http://spectrum.myriadcolours.com/~marnanel/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="eog"
+
+RDEPEND="sys-apps/dbus
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.24
+ net-misc/curl
+ eog? ( media-gfx/eog )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf $(use_enable eog)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake failed"
+ dodoc AUTHORS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if use eog; then
+ elog "Please note that in order to use the eog plugin, you have"
+ elog "to first enable it in [Edit -> Preferences -> Plugins]."
+ fi
+}
diff --git a/x11-plugins/imgur-integration/metadata.xml b/x11-plugins/imgur-integration/metadata.xml
new file mode 100644
index 000000000..de46dcb86
--- /dev/null
+++ b/x11-plugins/imgur-integration/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+<use>
+ <flag name='eog'>Build an imgur upload plugin for <pkg>media-gfx/eog</pkg></flag>
+</use>
+</pkgmetadata>