summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Garthe (the_mgt) <themgt@uncensored.citadel.org>2011-06-21 18:23:23 +0000
committerStefan Garthe (the_mgt) <themgt@uncensored.citadel.org>2011-06-21 18:23:23 +0000
commit93018cf28704a616cfc1442d25f944e525d4b18d (patch)
treee1f19699d07d7c4b8201f517388d02dc0791f2c5 /games-rpg/lipsofsuna/lipsofsuna-9999.ebuild
parentdev-python/parsedatetime: Support multiple python ABIs, rewrite testing and d... (diff)
downloadsunrise-reviewed-93018cf28704a616cfc1442d25f944e525d4b18d.tar.gz
sunrise-reviewed-93018cf28704a616cfc1442d25f944e525d4b18d.tar.bz2
sunrise-reviewed-93018cf28704a616cfc1442d25f944e525d4b18d.zip
games-rpg/lipsofsuna: New Ebuild for bug #372501, thanks to mgorny, floppym and Enlik for review and suggestions
svn path=/sunrise/; revision=12148
Diffstat (limited to 'games-rpg/lipsofsuna/lipsofsuna-9999.ebuild')
-rw-r--r--games-rpg/lipsofsuna/lipsofsuna-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-rpg/lipsofsuna/lipsofsuna-9999.ebuild b/games-rpg/lipsofsuna/lipsofsuna-9999.ebuild
new file mode 100644
index 000000000..f74e2d55e
--- /dev/null
+++ b/games-rpg/lipsofsuna/lipsofsuna-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+EGIT_REPO_URI="git://lipsofsuna.git.sourceforge.net/gitroot/lipsofsuna/lipsofsuna"
+EGIT_PROJECT="lipsofsuna"
+inherit eutils games waf-utils git-2
+
+DESCRIPTION="Tongue-in-cheek dungeon crawl game. Client and Server"
+HOMEPAGE="http://lipsofsuna.org/"
+SRC_URI=""
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-db/sqlite:3
+ >=dev-lang/lua-5.1.0
+ media-libs/flac
+ >=media-libs/glew-1.5
+ >=media-libs/libsdl-1.2
+ media-libs/libvorbis
+ media-libs/libogg
+ media-libs/mesa
+ media-libs/openal
+ >=media-libs/sdl-ttf-2.0
+ >=net-libs/enet-1
+ >=net-misc/curl-3
+ sci-physics/bullet"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ waf-utils_src_configure \
+ --relpath=false --optimize=true \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}"
+}
+
+src_install() {
+ dogamesbin .build/${PN} || die "Installation of gamesbinary failed"
+ insinto "${GAMES_DATADIR}"/${PN}/
+ doins -r data/* || die "Installation of game data failed"
+ doicon misc/${PN}.svg || die "Installation of Icon failed"
+ domenu misc/${PN}.desktop || die "Installation of desktop file failed"
+ prepgamesdirs
+}