summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2009-07-15 20:25:18 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2009-07-15 20:25:18 +0000
commitcbaa95620c47e37ca83e1ccba6ad05398ec89bf9 (patch)
tree77f802c00dc5fe964b0da02a07420d1d4c7b0e2f /games-emulation/lxdream/lxdream-0.9.1.ebuild
parentapp-text/pdfedit: Version bump. Fixed build issue reported in bug #277723 by ... (diff)
downloadsunrise-reviewed-cbaa95620c47e37ca83e1ccba6ad05398ec89bf9.tar.gz
sunrise-reviewed-cbaa95620c47e37ca83e1ccba6ad05398ec89bf9.tar.bz2
sunrise-reviewed-cbaa95620c47e37ca83e1ccba6ad05398ec89bf9.zip
games-emulation/lxdream: version bump, add profile and sdl USE flags
svn path=/sunrise/; revision=8829
Diffstat (limited to 'games-emulation/lxdream/lxdream-0.9.1.ebuild')
-rw-r--r--games-emulation/lxdream/lxdream-0.9.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-emulation/lxdream/lxdream-0.9.1.ebuild b/games-emulation/lxdream/lxdream-0.9.1.ebuild
new file mode 100644
index 000000000..db16c9a09
--- /dev/null
+++ b/games-emulation/lxdream/lxdream-0.9.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils games
+
+DESCRIPTION="An emulator for the Sega Dreamcast system"
+HOMEPAGE="http://www.lxdream.org/"
+SRC_URI="http://www.lxdream.org/count.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug esd profile pulseaudio sdl"
+
+RDEPEND="media-libs/alsa-lib
+ media-libs/libpng
+ esd? ( media-sound/esound )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl )
+ virtual/opengl
+ x11-libs/gtk+:2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ virtual/os-headers"
+
+src_compile() {
+ econf \
+ $(use_enable debug trace) \
+ $(use_enable debug watch) \
+ $(use_enable profile profiled) \
+ $(use_with esd) \
+ $(use_with pulseaudio pulse) \
+ $(use_with sdl)
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README || die "dodoc failed"
+ doicon pixmaps/${PN}.png || die "doicon failed"
+ domenu ${PN}.desktop || die "make_desktop_entry failed"
+ prepgamesdirs
+}