summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2008-01-13 14:41:52 +0000
committerJakub Moc <jakub@gentoo.org>2008-01-13 14:41:52 +0000
commit7f3fcb049028e666afa9b710524b3c9161af6573 (patch)
tree0e6a0240d6e00ffbe6fd3bb814bfac1beff7eac1 /app-misc
parentsunrise/x11-libs/pdcurses/pdcurses-2.8.ebuild: drop some unneeded WANT_AUTO* ... (diff)
downloadsunrise-reviewed-7f3fcb049028e666afa9b710524b3c9161af6573.tar.gz
sunrise-reviewed-7f3fcb049028e666afa9b710524b3c9161af6573.tar.bz2
sunrise-reviewed-7f3fcb049028e666afa9b710524b3c9161af6573.zip
app-misc/ccpublisher: Fix wx* and python handling
svn path=/sunrise/; revision=5389
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ccpublisher/ChangeLog5
-rw-r--r--app-misc/ccpublisher/Manifest4
-rw-r--r--app-misc/ccpublisher/ccpublisher-2.2.1.ebuild15
3 files changed, 16 insertions, 8 deletions
diff --git a/app-misc/ccpublisher/ChangeLog b/app-misc/ccpublisher/ChangeLog
index 9a71ac7ce..5044e98b6 100644
--- a/app-misc/ccpublisher/ChangeLog
+++ b/app-misc/ccpublisher/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for app-misc/ccpublisher
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 13 Jan 2008; Jakub Moc <jakub@gentoo.org> ccpublisher-2.2.1.ebuild:
+ Fix wx* and python handling
+
09 Jun 2007; Ali Polatel (hawking) <polatel@gmail.com>
ccpublisher-2.2.1.ebuild:
removed unused inherit eutils
diff --git a/app-misc/ccpublisher/Manifest b/app-misc/ccpublisher/Manifest
index 41509a0d2..8e3abfe2f 100644
--- a/app-misc/ccpublisher/Manifest
+++ b/app-misc/ccpublisher/Manifest
@@ -1,4 +1,4 @@
DIST ccPublisher-2.2.1.tar.gz 394556 RMD160 cf20f5817945f0ebf78026a3e4d8a31aa30009df SHA1 ace556d3169a014fe28ee8f44ade5492bb01a9f6 SHA256 ff9fb22487bb32831f5e4533a72b34b31f029711dcdaa0395e247e94300b9c46
-EBUILD ccpublisher-2.2.1.ebuild 1966 RMD160 4e41e34c0263eb756253639c01b6b1927e09a70f SHA1 c1e0e6d7256fd75e069ea24f7641a1574b08b637 SHA256 1c49a26b11c9e3a8071783c7b8448dfe115d292bb90f43badfdc4e15c9038136
-MISC ChangeLog 496 RMD160 10824afb3657aab2156c3766d481b4bce7ae2d57 SHA1 80dca0aa90781866d9d24ed173554b5f359cf461 SHA256 e0360720370cc9bc71f03d738e09af8d436bf6edce0a7b3a2fa623a06b6abf68
+EBUILD ccpublisher-2.2.1.ebuild 2023 RMD160 c5d61841eb4f9380835256f693e385acfffaffce SHA1 a62e1eb6f639ed2a368086bb42f64d9c1bbb559b SHA256 bb0af08c83386a48bdcae1284a7944ea0e91c6fe9c1f8516eb12f03310c1fc25
+MISC ChangeLog 597 RMD160 f2e745724e7989760f967301f716f838e2c89bd7 SHA1 92db42ca0066693b6c0980cbac47a3d35e718b5a SHA256 5fc29c2fa687bc9b48059333729fe2b22d850afc0842a344f16e961cd30a1987
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-misc/ccpublisher/ccpublisher-2.2.1.ebuild b/app-misc/ccpublisher/ccpublisher-2.2.1.ebuild
index 1eecdcd45..8de9b40a8 100644
--- a/app-misc/ccpublisher/ccpublisher-2.2.1.ebuild
+++ b/app-misc/ccpublisher/ccpublisher-2.2.1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit zproduct python multilib
+EAPI="1"
+WX_GTK_VER="2.6"
+inherit zproduct python multilib wxwidgets
MY_PN="ccPublisher"
MY_P="${MY_PN}-${PV}"
@@ -20,11 +22,10 @@ ZPROD_LIST="${MY_PN}"
S="${WORKDIR}/${MY_P}"
DEPEND=""
-RDEPEND=">=dev-python/wxpython-2.6.3.2
- >=x11-libs/wxGTK-2.6.3.3
+RDEPEND=">=dev-python/wxpython-2.6.3.2:2.6
+ >=x11-libs/wxGTK-2.6.3.3:2.6
zope? ( net-zope/zope )
|| ( ( dev-python/elementtree >=dev-lang/python-2.4 ) >=dev-lang/python-2.5 )"
- # wxGTK and wxpython have to be the same x.y.z version
src_install() {
# change directories, so that the python library is found
@@ -67,12 +68,16 @@ pkg_postrm() {
}
pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}usr/$(get_libdir)/${P}
+
elog
elog "ccPublisher is now installed to /usr/bin/ccPublisher"
elog
elog "If you get python errors, check that both wxpython and"
elog "wxGTK are the same version."
elog
+
if use zope; then
elog "The Zope Product has been installed."
elog "Use \"zprod-manager add\" to activate it."