aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-07-30 11:29:53 -0400
committerHorea Christian <chr@chymera.eu>2024-07-30 11:29:53 -0400
commitd703db1f390fd4005132b673b312715d73d6b7ef (patch)
treea1479afc389a84465f9955ee0d7cb5243cf813ac /dev-python
parentdev-python/hdmf: reordered variables (diff)
downloadsci-d703db1f390fd4005132b673b312715d73d6b7ef.tar.gz
sci-d703db1f390fd4005132b673b312715d73d6b7ef.tar.bz2
sci-d703db1f390fd4005132b673b312715d73d6b7ef.zip
dev-python/pynwb: add 2.8.1
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pynwb/Manifest1
-rw-r--r--dev-python/pynwb/pynwb-2.8.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pynwb/Manifest b/dev-python/pynwb/Manifest
index 0dffbb9ab..af90c66d6 100644
--- a/dev-python/pynwb/Manifest
+++ b/dev-python/pynwb/Manifest
@@ -1,2 +1,3 @@
DIST pynwb-2.5.0.tar.gz 620770 BLAKE2B 470f5127560bf79f112061e9e8af208051d76833e449a66b03e31bb0828ffbfd6aa0b9efc136ecc0b7efba758334c3f15525a41ec4540c6f55d02f8afbd55ab2 SHA512 cad84e3ac6c3c67c3c28e3c3ec44402bfc94c4cf988fbe64ddfa461a67115398b24bb9bcac1bd00933e1b63d73048d9b20ec6cd736a51d9f2c7bf4d294edb261
DIST pynwb-2.6.0.tar.gz 625188 BLAKE2B ac179af7e3c9de6ec4fb841dfd6279a1c3ba191b9d786553af02397a49c511f4a257a0e62f3b57a217ebb08588ad8ca64219fd435b3ec25776775d05e6a9ab9b SHA512 5c830cb37e8c6fe0643bd5bfee947565ddb1d0eff16dadadd3ebec7ec14a6e1ebcf34c3909ad05c3eedd8dd5f9e3669348216d695123f2013de0e969a403ec1c
+DIST pynwb-2.8.1.tar.gz 34769136 BLAKE2B b7fb44380b35edb07da5030c559ce5b7ffb73f7ffa4a00ce838544a124b644eb293232bcd6b9a3d999256eaa102e4ca68aff5302e3cdff342ba42a1fc9ebc403 SHA512 ba2c74b889b725f5abf20b337c9de89357900d5316cd2de0bff5548a1bf3fe80078c05e2652b8cfd76aedcab58457e86cb15e2decd9eb22729b148b3a7b28637
diff --git a/dev-python/pynwb/pynwb-2.8.1.ebuild b/dev-python/pynwb/pynwb-2.8.1.ebuild
new file mode 100644
index 000000000..5be67428b
--- /dev/null
+++ b/dev-python/pynwb/pynwb-2.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+#DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python API for working with Neurodata stored in the NWB Format "
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/pynwb"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+# Segfault error on testing
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/hdmf-3.14.3[${PYTHON_USEDEP}]
+ >=sci-libs/hdf5-1.12.2
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ "
+
+EPYTEST_DESELECT=(
+ # Reported upsream:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1580
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_bad_ns
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_core
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_extension
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_extension_pass_ns
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_hdmf_common
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_ignore
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_invalid
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_list_namespaces_core
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_list_namespaces_extension
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_no_cache
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_no_cache_bad_ns
+ # Reported upstream:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1800
+ tests/unit/test_file.py::TestNoCacheSpec::test_simple
+ # Not sandboxed, reported upstream:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1800
+ tests/read_dandi/test_read_dandi.py::TestReadNWBDandisets::test_read_first_nwb_asset
+ tests/unit/test_base.py::TestTimeSeries::test_repr_html
+)
+
+distutils_enable_tests pytest