aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-03 20:53:26 +0100
committerHorea Christian <chr@chymera.eu>2021-01-03 17:51:39 -0500
commit8b283e74923232709162d4166cb1c16643f7cb7d (patch)
tree21dc6255fe96925736732457aa4b38d4e1f6b110 /app-text
parentdev-java/jeuclid-core: EAPI bump, version bump, add keyword (diff)
downloadsci-8b283e74923232709162d4166cb1c16643f7cb7d.tar.gz
sci-8b283e74923232709162d4166cb1c16643f7cb7d.tar.bz2
sci-8b283e74923232709162d4166cb1c16643f7cb7d.zip
app-text/zotero-bin: new pack: Your personal research assistant
Helps lookup and manage citations and stuff This is java package and the build system is not supported by portage, hence this is -bin Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zotero-bin/Manifest1
-rw-r--r--app-text/zotero-bin/metadata.xml11
-rw-r--r--app-text/zotero-bin/zotero-bin-5.0.94.ebuild53
3 files changed, 65 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
new file mode 100644
index 000000000..4b9f2e86b
--- /dev/null
+++ b/app-text/zotero-bin/Manifest
@@ -0,0 +1 @@
+DIST zotero-bin-5.0.94-5.0.94.tar.bz2 60370388 BLAKE2B 8d9d4e5aa18e922dedd66e629c6c9fe8d059e8539c5b02514f554a3a18a3756cce8fab7af63b08c25a0a375d1dfc324dba16717f6332809425457010fc139c8f SHA512 31a730b4e1ec0f4821e16f8853d4237d14569372900c76fdfd950bba893e3203a01cdd896f64b0a6ea451c8d19ab94db45f617f040366a5d0496efab632c198f
diff --git a/app-text/zotero-bin/metadata.xml b/app-text/zotero-bin/metadata.xml
new file mode 100644
index 000000000..8bf43532d
--- /dev/null
+++ b/app-text/zotero-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zotero/zotero</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/zotero-bin/zotero-bin-5.0.94.ebuild b/app-text/zotero-bin/zotero-bin-5.0.94.ebuild
new file mode 100644
index 000000000..3da15fe09
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-5.0.94.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/dbus-glib
+ dev-libs/nss
+ x11-libs/gtk+:3
+ x11-libs/libXt
+"
+
+S="${WORKDIR}/Zotero_linux-x86_64"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ # disable update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop
+
+ default
+}
+
+src_install() {
+ dodir opt/zotero
+ cp -a "${S}"/* "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}