aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-30 20:00:37 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-30 20:56:43 -0500
commit8f478fe30ba9f3a43df0753fc8369f93b509f4af (patch)
tree5e8ce0715b858b348ed73d92ed12d81b12afa545 /tools/catalyst-auto-x86.conf
parenttools: Use same set of RSYNC_OPTS (diff)
downloadreleng-8f478fe30ba9f3a43df0753fc8369f93b509f4af.tar.gz
releng-8f478fe30ba9f3a43df0753fc8369f93b509f4af.tar.bz2
releng-8f478fe30ba9f3a43df0753fc8369f93b509f4af.zip
tools: Add UPLOAD_DEST
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'tools/catalyst-auto-x86.conf')
-rw-r--r--tools/catalyst-auto-x86.conf18
1 files changed, 3 insertions, 15 deletions
diff --git a/tools/catalyst-auto-x86.conf b/tools/catalyst-auto-x86.conf
index 1c809465..bb779d7e 100644
--- a/tools/catalyst-auto-x86.conf
+++ b/tools/catalyst-auto-x86.conf
@@ -67,26 +67,14 @@ upload() {
--omit-dir-times
--delay-updates
)
- rsync "${RSYNC_OPTS[@]}" "$@" ${UPLOAD_DEST}
+ rsync "${RSYNC_OPTS[@]}" "$@" ${UPLOAD_USER}@releng-incoming.gentoo.org:${UPLOAD_DEST}
}
post_build() {
local set=$1 spec=$2
- case $HOSTNAME in
- # If you ever need to ensure it's copied somewhere local, drop a hostname in here!
- LOCAL)
- DEST_DEFAULT=${BUILD_DESTDIR_BASE}
- DEST_HARDENED=${BUILD_DESTDIR_BASE}/hardened
- ;;
- *)
- DEST_DEFAULT=${UPLOAD_USER}@releng-incoming.gentoo.org:${BUILD_DESTDIR_BASE}
- DEST_HARDENED=${UPLOAD_USER}@releng-incoming.gentoo.org:${BUILD_DESTDIR_BASE}/hardened
- ;;
- esac
-
pushd "${BUILD_SRCDIR_BASE}"/default >/dev/null || exit
- UPLOAD_DEST=${DEST_DEFAULT}
+ UPLOAD_DEST=${BUILD_DESTDIR_BASE}
case ${spec} in
stage3.spec)
upload stage3-i486-${TIMESTAMP}.tar.xz*
@@ -104,7 +92,7 @@ post_build() {
popd >/dev/null || exit
pushd "${BUILD_SRCDIR_BASE}"/hardened >/dev/null || exit
- UPLOAD_DEST=${DEST_HARDENED}
+ UPLOAD_DEST=${BUILD_DESTDIR_BASE}/hardened
case ${spec} in
hardened/stage3.spec)
upload stage3-i686-hardened-${TIMESTAMP}.tar.xz*