aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-21 21:18:18 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-04-21 22:49:29 +0300
commitf85b608ccfb5d2d81a5d086773f75b0da74a5ff6 (patch)
treee2f999c63b21899cf7dbade7750e4c464b08f06e
parentapp-arch/lxqt-archiver: add 1.0.0 (diff)
downloadqt-f85b608ccfb5d2d81a5d086773f75b0da74a5ff6.tar.gz
qt-f85b608ccfb5d2d81a5d086773f75b0da74a5ff6.tar.bz2
qt-f85b608ccfb5d2d81a5d086773f75b0da74a5ff6.zip
gui-libs/xdg-desktop-portal-lxqt: add 9999, 1.0.1
Initial qt6 version. Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/metadata.xml11
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.1.ebuild30
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-9999.ebuild30
4 files changed, 72 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-lxqt/Manifest b/gui-libs/xdg-desktop-portal-lxqt/Manifest
new file mode 100644
index 00000000..f3d1205d
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/Manifest
@@ -0,0 +1 @@
+DIST xdg-desktop-portal-lxqt-1.0.1.tar.xz 16204 BLAKE2B 1b94cd95bb944907aca53f905316f11ce437076c552489f982cca235fb75cef991a88e8a7598eb63cca6f261f813e56935bc3cd6732e992be0b749b77fbfde01 SHA512 3b67e9c6fc6225b498f7f7e65d50658395e8e37189e964b831b1ce3c9cb477144ff73c97da3e8cac07ee918d95c8626076de60ab3a0686665c3d4344fd688c5f
diff --git a/gui-libs/xdg-desktop-portal-lxqt/metadata.xml b/gui-libs/xdg-desktop-portal-lxqt/metadata.xml
new file mode 100644
index 00000000..d128d8a4
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/xdg-desktop-portal-lxqt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.1.ebuild b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.1.ebuild
new file mode 100644
index 00000000..8472248f
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Qt/KF5/libfm-qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-2.0.0"
+DEPEND="
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets]
+ kde-frameworks/kwindowsystem:6
+ >=x11-libs/libfm-qt-2.0:=
+"
+RDEPEND="${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
diff --git a/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-9999.ebuild b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-9999.ebuild
new file mode 100644
index 00000000..8472248f
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Qt/KF5/libfm-qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-2.0.0"
+DEPEND="
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets]
+ kde-frameworks/kwindowsystem:6
+ >=x11-libs/libfm-qt-2.0:=
+"
+RDEPEND="${DEPEND}
+ sys-apps/xdg-desktop-portal
+"