aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-11-06 15:19:43 +0200
committerJimi Huotari <chiitoo@gentoo.org>2024-11-06 15:20:06 +0200
commit3cc59f68acdb7027b1ff1c7fa724ca7de6b1bdc1 (patch)
tree52e56ffbd4acb7452eb7bcb745a30b915deac1ff
parentdev-util/lxqt-build-tools: sync keywords and update dependencies (diff)
downloadqt-3cc59f68acdb7027b1ff1c7fa724ca7de6b1bdc1.tar.gz
qt-3cc59f68acdb7027b1ff1c7fa724ca7de6b1bdc1.tar.bz2
qt-3cc59f68acdb7027b1ff1c7fa724ca7de6b1bdc1.zip
app-arch/lxqt-archiver: sync keywords and update dependencies
Also use 'xdg' instead of 'xdg-utils'. Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild
index 6013e544..2fb3286e 100644
--- a/app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild
+++ b/app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
MY_PV="$(ver_cut 1-2)"
-inherit cmake xdg-utils
+inherit cmake xdg
DESCRIPTION="Qt GUI File Archiver"
HOMEPAGE="https://lxqt-project.org/"
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
LICENSE="GPL-2 GPL-2+"
@@ -23,19 +23,18 @@ SLOT="0"
BDEPEND="
>=dev-qt/qttools-6.6:6[linguist]
- >=dev-util/lxqt-build-tools-2.0.0
+ >=dev-util/lxqt-build-tools-2.1.0
"
DEPEND="
dev-libs/glib:2
dev-libs/json-glib
>=dev-qt/qtbase-6.6:6[gui,widgets]
- >=x11-libs/libfm-qt-2.0:=
+ >=x11-libs/libfm-qt-2.1:=
"
RDEPEND="${DEPEND}"
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
+ default
elog "Please note that this is only a graphical front-end, and additional"
elog "packages are needed to have support for specific file formats."
@@ -44,7 +43,3 @@ pkg_postinst() {
elog "For the full list of supported formats, see the 'README.md' file:"
elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}