aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-01-02 12:17:53 +0100
committerFabian Groffen <grobian@gentoo.org>2020-01-02 12:17:53 +0100
commit24e232b949803a0d650387c61eb32c95d7270647 (patch)
treeff585c3918d76d1a2390d924f4b366c3b5013fd7 /qdepends.c
parentlibq/atom: also strip/ignore .tbz2 suffix (like .ebuild) (diff)
downloadportage-utils-24e232b949803a0d650387c61eb32c95d7270647.tar.gz
portage-utils-24e232b949803a0d650387c61eb32c95d7270647.tar.bz2
portage-utils-24e232b949803a0d650387c61eb32c95d7270647.zip
libq/tree: have tree_foreach_pkg take a query atom
Allow to reduce the search by having a query atom. This will skip categories and packages not matching the atom, possibly avoiding lots of work. This needs to be exploited from applets where necessary. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'qdepends.c')
-rw-r--r--qdepends.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/qdepends.c b/qdepends.c
index 9969d90..44821b6 100644
--- a/qdepends.c
+++ b/qdepends.c
@@ -1,5 +1,5 @@
/*
- * Copyright 2005-2019 Gentoo Authors
+ * Copyright 2005-2020 Gentoo Authors
* Distributed under the terms of the GNU General Public License v2
*
* Copyright 2005-2010 Ned Ludd - <solar@gentoo.org>
@@ -376,7 +376,7 @@ int qdepends_main(int argc, char **argv)
t = tree_open(portroot, overlay);
if (t != NULL) {
ret = tree_foreach_pkg_sorted(t,
- qdepends_results_cb, &state);
+ qdepends_results_cb, &state, NULL);
tree_close(t);
}
}