aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-04-14 17:30:08 +0200
committerFabian Groffen <grobian@gentoo.org>2019-04-14 17:30:08 +0200
commit26d7b53a7c1ac02db37ccf6086c60c1c004e2ebb (patch)
treee19a9b825b6b7740b86277ce884213fe3e43fb9d /configure.ac
parentbuild: cleanup Makfile preparing for dist (diff)
downloadportage-utils-26d7b53a7c1ac02db37ccf6086c60c1c004e2ebb.tar.gz
portage-utils-26d7b53a7c1ac02db37ccf6086c60c1c004e2ebb.tar.bz2
portage-utils-26d7b53a7c1ac02db37ccf6086c60c1c004e2ebb.zip
build: cleanup and standardise tests running
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 902071d..fffaf51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,9 @@ case "$with_eprefix" in
*/) with_eprefix="$with_eprefix" ;;
*) with_eprefix="${with_eprefix}/" ;;
esac
-AC_DEFINE_UNQUOTED([CONFIG_EPREFIX], ["$with_eprefix"], [path for Gentoo/Prefix project])
+AC_DEFINE_UNQUOTED([CONFIG_EPREFIX], ["$with_eprefix"],
+ [Gentoo Prefix offset path])
+AC_SUBST([CONFIG_EPREFIX], ["$with_eprefix"])
AX_CFLAGS_WARN_ALL
AC_DEFUN([PT_CHECK_CFLAG],[AX_CHECK_COMPILER_FLAGS([$1],[CFLAGS="$CFLAGS $1"])])
@@ -59,9 +61,26 @@ AC_CONFIG_FILES([
Makefile
libq/Makefile
autotools/gnulib/Makefile
+ tests/init.sh
+ tests/Makefile
+ tests/atom_compare/Makefile
tests/atom_explode/Makefile
tests/copy_file/Makefile
+ tests/install/Makefile
tests/mkdir/Makefile
+ tests/profile/Makefile
+ tests/qatom/Makefile
+ tests/qcheck/Makefile
+ tests/qdepends/Makefile
+ tests/qfile/Makefile
+ tests/qlist/Makefile
+ tests/qlop/Makefile
+ tests/qmerge/Makefile
+ tests/qtbz2/Makefile
+ tests/quse/Makefile
+ tests/qxpak/Makefile
+ tests/reinitialize/Makefile
tests/rmspace/Makefile
+ tests/source/Makefile
])
AC_OUTPUT