aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-09 22:02:12 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-09 22:02:12 +0200
commitd3c5be6fe4b20c405246950de3ac734068db372e (patch)
tree222a5ba7a53cd67b438e459b65a1882b7d1b2b9b /testdata
parentdrop py3.8 and make py3.11 official (diff)
downloadpkgcheck-d3c5be6fe4b20c405246950de3ac734068db372e.tar.gz
pkgcheck-d3c5be6fe4b20c405246950de3ac734068db372e.tar.bz2
pkgcheck-d3c5be6fe4b20c405246950de3ac734068db372e.zip
UnquotedVariable: fix false positives with unset_command
Caught on sci-biology/hmmer, it was incorrectly reporting for TMPDIR declared with `unset`. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'testdata')
-rw-r--r--testdata/repos/standalone/EbuildUnquotedVariablesCheck/EbuildUnquotedVariable/EbuildUnquotedVariable-0.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/testdata/repos/standalone/EbuildUnquotedVariablesCheck/EbuildUnquotedVariable/EbuildUnquotedVariable-0.ebuild b/testdata/repos/standalone/EbuildUnquotedVariablesCheck/EbuildUnquotedVariable/EbuildUnquotedVariable-0.ebuild
index 0c382b1b..30ff4887 100644
--- a/testdata/repos/standalone/EbuildUnquotedVariablesCheck/EbuildUnquotedVariable/EbuildUnquotedVariable-0.ebuild
+++ b/testdata/repos/standalone/EbuildUnquotedVariablesCheck/EbuildUnquotedVariable/EbuildUnquotedVariable-0.ebuild
@@ -44,4 +44,6 @@ src_prepare() {
local TMPDIR # ok
TMPDIR="$(mktemp --directory --tmpdir=/tmp ${PN}-XXXX)" # ok
export TMPDIR # ok
+
+ unset TMPDIR # ok
}