aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>1998-11-26 10:18:33 +0000
committerPhil Blundell <philb@gnu.org>1998-11-26 10:18:33 +0000
commit4eec9b724304fa33423973df345353a53a0bbd6b (patch)
tree88b63bb4bd90e177d4923a3605157891703f6af5 /Makefile
parentMore #include "util.h" (diff)
downloadnet-tools-4eec9b724304fa33423973df345353a53a0bbd6b.tar.gz
net-tools-4eec9b724304fa33423973df345353a53a0bbd6b.tar.bz2
net-tools-4eec9b724304fa33423973df345353a53a0bbd6b.zip
Added RPM packaging stuff.
Various small makefile tweaks. Released as 1.48
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index 204359f..adbb270 100644
--- a/Makefile
+++ b/Makefile
@@ -73,13 +73,13 @@
# BASEDIR = /mnt
# path to the net-lib support library. Default: lib
-NET-LIB-PATH = lib
-NET-LIB-NAME = support
+NET_LIB_PATH = lib
+NET_LIB_NAME = net-tools
PROGS = ifconfig hostname arp netstat route rarp
# Compiler and Linker Options
-# You may need to uncomment and edit these if you are using libc5.
+# You may need to uncomment and edit these if you are using libc5 and IPv6.
COPTS = -D_GNU_SOURCE -O2 -Wall -g # -I/usr/inet6/include
LOPTS =
RESLIB = # -L/usr/inet6/lib -linet6
@@ -91,23 +91,23 @@ RELEASE = 1.48
.EXPORT_ALL_VARIABLES:
-ifeq ("$(NET-LIB-PATH)","lib2")
+ifeq ("$(NET_LIB_PATH)","lib2")
TOPDIR = ..
else
TOPDIR := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi)
endif
-NET-LIB = $(NET-LIB-PATH)/lib$(NET-LIB-NAME).a
+NET-LIB = $(NET_LIB_PATH)/lib$(NET_LIB_NAME).a
-CFLAGS = $(COPTS) -I. -I./include/ -I$(NET-LIB-PATH)
-LDFLAGS = $(LOPTS) -L$(NET-LIB-PATH)
+CFLAGS = $(COPTS) -I. -I./include/ -I$(NET_LIB_PATH)
+LDFLAGS = $(LOPTS) -L$(NET_LIB_PATH)
-SUBDIRS = man/ $(NET-LIB-PATH)/
+SUBDIRS = man/ $(NET_LIB_PATH)/
CC = gcc
LD = gcc
-NLIB = -l$(NET-LIB-NAME)
+NLIB = -l$(NET_LIB_NAME)
MDEFINES = COPTS='$(COPTS)' LOPTS='$(LOPTS)' TOPDIR='$(TOPDIR)'
@@ -156,7 +156,7 @@ $(NET-LIB): config.h version.h intl.h libdir
i18n.h: i18ndir
libdir:
- @$(MAKE) -C $(NET-LIB-PATH) $(MDEFINES)
+ @$(MAKE) -C $(NET_LIB_PATH) $(MDEFINES)
i18ndir:
@$(MAKE) -C po