aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-01-28 13:47:27 -0600
committerJory Pratt <anarchy@gentoo.org>2020-01-28 13:47:27 -0600
commit2a586aa797edf9f3166f3d90ed30859a147559d6 (patch)
treeabcd6c45f065877564ef32102af48c2fafad1ae9 /dev-lang
parent*/*: [QA] Fix trivial cases of MissingTestRestrict (diff)
downloadmusl-2a586aa797edf9f3166f3d90ed30859a147559d6.tar.gz
musl-2a586aa797edf9f3166f3d90ed30859a147559d6.tar.bz2
musl-2a586aa797edf9f3166f3d90ed30859a147559d6.zip
remove packages that are working in ::gentoo
Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go-bootstrap/Manifest1
-rw-r--r--dev-lang/go-bootstrap/go-bootstrap-1.4.3.ebuild81
-rw-r--r--dev-lang/go-bootstrap/metadata.xml13
-rw-r--r--dev-lang/go/Manifest1
-rw-r--r--dev-lang/go/go-1.10.3.ebuild200
-rw-r--r--dev-lang/go/metadata.xml13
-rw-r--r--dev-lang/spidermonkey/Manifest2
-rw-r--r--dev-lang/spidermonkey/files/moz38-dont-hardcode-libc-soname.patch15
-rw-r--r--dev-lang/spidermonkey/files/spidermonkey-52.0-fix-alpha-bitness.patch32
-rw-r--r--dev-lang/spidermonkey/files/spidermonkey-musl.patch13
-rw-r--r--dev-lang/spidermonkey/files/spidermonkey-threadlocal.patch14
-rw-r--r--dev-lang/spidermonkey/metadata.xml17
-rw-r--r--dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild149
13 files changed, 0 insertions, 551 deletions
diff --git a/dev-lang/go-bootstrap/Manifest b/dev-lang/go-bootstrap/Manifest
deleted file mode 100644
index bc049a4b..00000000
--- a/dev-lang/go-bootstrap/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST go1.4.3.src.tar.gz 10875170 BLAKE2B a094d0ed36f9d581b003e022f10692ed929f2da7508ac2079a83c1e4e3a24bd89b33a468ba2c27b658245682acddf65e4db5f4b09b699778e093ad387a64c1f5 SHA512 12bade4bce9aa4b34e2b9495ae65a1fc6a2449b3a43bc4de85c8b87ba223c2f999b2f37c1e2fe1188d8521118b5e5357d27afb8b85c0b8ebb4503d4125d25273
diff --git a/dev-lang/go-bootstrap/go-bootstrap-1.4.3.ebuild b/dev-lang/go-bootstrap/go-bootstrap-1.4.3.ebuild
deleted file mode 100644
index e52034a5..00000000
--- a/dev-lang/go-bootstrap/go-bootstrap-1.4.3.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-export CTARGET=${CTARGET:-${CHOST}}
-
-inherit eutils toolchain-funcs
-
-SRC_URI="https://storage.googleapis.com/golang/go${PV}.src.tar.gz"
-# Upstream only supports go on amd64, arm and x86 architectures.
-KEYWORDS="-* amd64"
-
-DESCRIPTION="Version of go compiler used for bootstrapping"
-HOMEPAGE="http://www.golang.org"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-# The go tools should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go1.4/pkg/tool/.*/.*"
-
-# The go language uses *.a files which are _NOT_ libraries and should not be
-# stripped. The test data objects should also be left alone and unstripped.
-STRIP_MASK="/usr/lib/go1.4/pkg/*.a
- /usr/lib/go1.4/src/debug/elf/testdata/*
- /usr/lib/go1.4/src/debug/dwarf/testdata/*
- /usr/lib/go1.4/src/runtime/race/*.syso"
-
-S="${WORKDIR}"/go
-
-src_prepare() {
- sed -i -e 's/"-Werror",//g' src/cmd/dist/build.c
- eapply_user
-}
-
-src_compile() {
- export GOROOT_FINAL="${EPREFIX}"/usr/lib/go1.4
- export GOROOT="$(pwd)"
- export GOBIN="${GOROOT}/bin"
- export CGO_ENABLED=0
- if [[ $CTARGET = armv5* ]]
- then
- export GOARM=5
- fi
- tc-export CC
-
- cd src
- ./make.bash || die "build failed"
-}
-
-src_test() {
- cd src
- PATH="${GOBIN}:${PATH}" \
- ./run.bash --no-rebuild --banner || die "tests failed"
-}
-
-src_install() {
- dodir /usr/lib/go1.4
- exeinto /usr/lib/go1.4/bin
- doexe bin/*
- insinto /usr/lib/go1.4
- doins -r lib pkg src
- fperms -R +x /usr/lib/go1.4/pkg/tool
-}
-
-pkg_postinst() {
- # If the go tool sees a package file timestamped older than a dependancy it
- # will rebuild that file. So, in order to stop go from rebuilding lots of
- # packages for every build we need to fix the timestamps. The compiler and
- # linker are also checked - so we need to fix them too.
- ebegin "fixing timestamps to avoid unnecessary rebuilds"
- tref="usr/lib/go1.4/pkg/*/runtime.a"
- find "${EROOT}"usr/lib/go1.4 -type f \
- -exec touch -r "${EROOT}"${tref} {} \;
- eend $?
-}
diff --git a/dev-lang/go-bootstrap/metadata.xml b/dev-lang/go-bootstrap/metadata.xml
deleted file mode 100644
index a70f51b2..00000000
--- a/dev-lang/go-bootstrap/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>williamh@gentoo.org</email>
- <name>William Hubbs</name>
- </maintainer>
- <longdescription lang="en">
- This package is only necessary until gccgo supports go-1.4. It
- will be removed as soon as stable gcc supports this.
- It is here so that &gt;=dev-lang/go 1.5 can use it to bootstrap.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-lang/go/Manifest b/dev-lang/go/Manifest
deleted file mode 100644
index 48833053..00000000
--- a/dev-lang/go/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST go1.10.3.src.tar.gz 18323736 BLAKE2B f07ea774378eb25e28fc29ce6d8d7ed84227d4b93bfa93d38a071fe294da30c3cdc3a559d643e7379873df56b0e2731dbd772e385ffcb4b2e93819db3b4e33f2 SHA512 fd2bd5fcb5c6d0a5336c4b1d2cacb368edbb01359297a83bdedc53f6018642598232f00633fc60fde879050f5f26a810c828d46b5d6626cbcc0702d93ad33fbb
diff --git a/dev-lang/go/go-1.10.3.ebuild b/dev-lang/go/go-1.10.3.ebuild
deleted file mode 100644
index 02de3bc5..00000000
--- a/dev-lang/go/go-1.10.3.ebuild
+++ /dev/null
@@ -1,200 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-
-MY_PV=${PV/_/}
-
-inherit toolchain-funcs
-
-case ${PV} in
-*9999*)
- EGIT_REPO_URI="https://github.com/golang/go.git"
- inherit git-r3
- ;;
-*)
- SRC_URI="https://storage.googleapis.com/golang/go${MY_PV}.src.tar.gz "
- S="${WORKDIR}"/go
- case ${PV} in
- *_beta*|*_rc*) ;;
- *)
- KEYWORDS="-* amd64"
- #KEYWORDS="-* amd64 arm ~arm64 ~ppc64 ~s390 x86 ~x64-macos ~x64-solaris"
- # The upstream tests fail under portage but pass if the build is
- # run according to their documentation [1].
- # I am restricting the tests on released versions until this is
- # solved.
- # [1] https://golang.org/issues/18442
- RESTRICT="test"
- ;;
- esac
-esac
-
-DESCRIPTION="A concurrent garbage collected and typesafe programming language"
-HOMEPAGE="https://golang.org"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-IUSE=""
-
-DEPEND="dev-lang/go-bootstrap"
-RDEPEND="!<dev-go/go-tools-0_pre20150902"
-
-# These test data objects have writable/executable stacks.
-QA_EXECSTACK="
- usr/lib/go/src/debug/elf/testdata/*.obj
- usr/lib/go/src/go/internal/gccgoimporter/testdata/escapeinfo.gox
- usr/lib/go/src/go/internal/gccgoimporter/testdata/unicode.gox
- usr/lib/go/src/go/internal/gccgoimporter/testdata/time.gox
- "
-
-# Do not complain about CFLAGS, etc, since Go doesn't use them.
-QA_FLAGS_IGNORED='.*'
-
-REQUIRES_EXCLUDE="/usr/lib/go/src/debug/elf/testdata/*"
-
-# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
-
-# Do not strip this package. Stripping is unsupported upstream and may
-# fail.
-RESTRICT+=" strip"
-
-DOCS=(
-AUTHORS
-CONTRIBUTING.md
-CONTRIBUTORS
-PATENTS
-README.md
-)
-
-go_arch()
-{
- # By chance most portage arch names match Go
- local portage_arch=$(tc-arch $@)
- case "${portage_arch}" in
- x86) echo 386;;
- x64-*) echo amd64;;
- ppc64) [[ $(tc-endian $@) = big ]] && echo ppc64 || echo ppc64le ;;
- s390) echo s390x ;;
- *) echo "${portage_arch}";;
- esac
-}
-
-go_arm()
-{
- case "${1:-${CHOST}}" in
- armv5*) echo 5;;
- armv6*) echo 6;;
- armv7*) echo 7;;
- *)
- die "unknown GOARM for ${1:-${CHOST}}"
- ;;
- esac
-}
-
-go_os()
-{
- case "${1:-${CHOST}}" in
- *-linux*) echo linux;;
- *-darwin*) echo darwin;;
- *-freebsd*) echo freebsd;;
- *-netbsd*) echo netbsd;;
- *-openbsd*) echo openbsd;;
- *-solaris*) echo solaris;;
- *-cygwin*|*-interix*|*-winnt*)
- echo windows
- ;;
- *)
- die "unknown GOOS for ${1:-${CHOST}}"
- ;;
- esac
-}
-
-go_tuple()
-{
- echo "$(go_os $@)_$(go_arch $@)"
-}
-
-go_cross_compile()
-{
- [[ $(go_tuple ${CBUILD}) != $(go_tuple) ]]
-}
-
-pkg_pretend()
-{
- # make.bash does not understand cross-compiling a cross-compiler
- if [[ $(go_tuple) != $(go_tuple ${CTARGET}) ]]; then
- die "CHOST CTARGET pair unsupported: CHOST=${CHOST} CTARGET=${CTARGET}"
- fi
-}
-
-src_unpack()
-{
- if [[ ${PV} = 9999 ]]; then
- git-r3_src_unpack
- fi
- default
-}
-
-src_compile()
-{
- export GOROOT_BOOTSTRAP="/usr/lib/go1.4"
- export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
- export GOROOT="$(pwd)"
- export GOBIN="${GOROOT}/bin"
-
- # Go's build script does not use BUILD/HOST/TARGET consistently. :(
- export GOHOSTARCH=$(go_arch ${CBUILD})
- export GOHOSTOS=$(go_os ${CBUILD})
- export CC=$(tc-getBUILD_CC)
-
- export GOARCH=$(go_arch)
- export GOOS=$(go_os)
- export CC_FOR_TARGET=$(tc-getCC)
- export CXX_FOR_TARGET=$(tc-getCXX)
- if [[ ${ARCH} == arm ]]; then
- export GOARM=$(go_arm)
- fi
- einfo "GOROOT_BOOTSTRAP is ${GOROOT_BOOTSTRAP}"
-
- cd src
- ./make.bash || die "build failed"
-}
-
-src_test()
-{
- go_cross_compile && return 0
-
- cd src
- PATH="${GOBIN}:${PATH}" \
- ./run.bash -no-rebuild || die "tests failed"
-}
-
-src_install()
-{
- local bin_path f x
-
- dodir /usr/lib/go
-
- # There is a known issue which requires the source tree to be installed [1].
- # Once this is fixed, we can consider using the doc use flag to control
- # installing the doc and src directories.
- # [1] https://golang.org/issue/2775
- #
- # deliberately use cp to retain permissions
- cp -R api bin doc lib pkg misc src test "${ED}"/usr/lib/go
- if go_cross_compile; then
- bin_path="bin/$(go_tuple)"
- else
- bin_path=bin
- fi
- for x in ${bin_path}/*; do
- f=${x##*/}
- dosym ../lib/go/${bin_path}/${f} /usr/bin/${f}
- done
- einstalldocs
-}
diff --git a/dev-lang/go/metadata.xml b/dev-lang/go/metadata.xml
deleted file mode 100644
index 1050d935..00000000
--- a/dev-lang/go/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>williamh@gentoo.org</email>
- <name>William Hubbs</name>
- </maintainer>
- <longdescription lang="en">
- Go is a new systems programming language developped at google by
- Rob Pike. It has garbage collection, coroutines, communication
- channels and a clean syntax.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-lang/spidermonkey/Manifest b/dev-lang/spidermonkey/Manifest
deleted file mode 100644
index 17a7f619..00000000
--- a/dev-lang/spidermonkey/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST mozjs-52.9.1pre1.tar.bz2 30178574 BLAKE2B 0920432b5140e78297a9bcbccb54268d75a223d5e75e4ff90b3b01aab4f7736b4a4e05c47b3a925ff0a74607a0abad3b6583c75d070ef5142009b20ebaf6e4bf SHA512 187b231b246a5ae09e55c0fef77866b316d75f38f4c2e066d5d4325d8da63433027020c929439cab46af3253ac63ab2f780223a8fd2c6ff535b3409bb6c4aa0f
-DIST spidermonkey-52.0-patches-0.tar.xz 5172 BLAKE2B 8bcf9477de47ef3b882cd3281efa7f77c16ce11fc93f44446a620917adf629fde8290af1dd69f0930a889aacfee3603bf60eb9c1e718a1dfd3e218a1013b6192 SHA512 88ad640fb0efa4972f1b7782bd0abee1751b73914ee51faade93b25c4d8eec64e7693898842a406c49fc2ab43733404efeccb138afb64d2193b9a5eb612578e3
diff --git a/dev-lang/spidermonkey/files/moz38-dont-hardcode-libc-soname.patch b/dev-lang/spidermonkey/files/moz38-dont-hardcode-libc-soname.patch
deleted file mode 100644
index 708c7496..00000000
--- a/dev-lang/spidermonkey/files/moz38-dont-hardcode-libc-soname.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/testing/mozbase/mozinfo/mozinfo/mozinfo.py 2018-01-12 12:21:16.764318254 -0500
-+++ b/testing/mozbase/mozinfo/mozinfo/mozinfo.py 2018-01-12 12:22:23.392069398 -0500
-@@ -93,10 +93,11 @@
-
- if info['os'] == 'linux':
- import ctypes
-+ import ctypes.util
- import errno
- PR_SET_SECCOMP = 22
- SECCOMP_MODE_FILTER = 2
-- ctypes.CDLL("libc.so.6", use_errno=True).prctl(PR_SET_SECCOMP, SECCOMP_MODE_FILTER, 0)
-+ ctypes.CDLL(ctypes.util.find_library('c'), use_errno=True).prctl(PR_SET_SECCOMP, SECCOMP_MODE_FILTER, 0)
- info['has_sandbox'] = ctypes.get_errno() == errno.EFAULT
- else:
- info['has_sandbox'] = True
diff --git a/dev-lang/spidermonkey/files/spidermonkey-52.0-fix-alpha-bitness.patch b/dev-lang/spidermonkey/files/spidermonkey-52.0-fix-alpha-bitness.patch
deleted file mode 100644
index b0f87296..00000000
--- a/dev-lang/spidermonkey/files/spidermonkey-52.0-fix-alpha-bitness.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-
-# HG changeset patch
-# User John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-# Date 1482966103 -3600
-# Node ID 1f4d99d8dff27bcc25eff21dc6a16dae63f48595
-# Parent ce9e9f0dc752896ac7ba00bb0610b3f731e948b0
-Bug 1326496 - mozbuild: Fix bitness from 32 to 64 bits on alpha. r=glandium
-
-
-diff --git a/python/mozbuild/mozbuild/configure/constants.py b/python/mozbuild/mozbuild/configure/constants.py
---- a/python/mozbuild/mozbuild/configure/constants.py
-+++ b/python/mozbuild/mozbuild/configure/constants.py
-@@ -35,17 +35,17 @@ Kernel = EnumString.subclass(
- 'Linux',
- 'NetBSD',
- 'OpenBSD',
- 'WINNT',
- )
-
- CPU_bitness = {
- 'aarch64': 64,
-- 'Alpha': 32,
-+ 'Alpha': 64,
- 'arm': 32,
- 'hppa': 32,
- 'ia64': 64,
- 'mips32': 32,
- 'mips64': 64,
- 'ppc': 32,
- 'ppc64': 64,
- 's390': 32,
-
diff --git a/dev-lang/spidermonkey/files/spidermonkey-musl.patch b/dev-lang/spidermonkey/files/spidermonkey-musl.patch
deleted file mode 100644
index b4756379..00000000
--- a/dev-lang/spidermonkey/files/spidermonkey-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Fixes "caddr_t undeclared" compile error
-
-diff -ur mozjs-52.9.1pre1.orig/python/psutil/psutil/_psutil_linux.c mozjs-52.9.1pre1/python/psutil/psutil/_psutil_linux.c
---- mozjs-52.9.1pre1.orig/python/psutil/psutil/_psutil_linux.c 2018-07-23 18:00:01.000000000 +0000
-+++ mozjs-52.9.1pre1/python/psutil/psutil/_psutil_linux.c 2018-11-25 20:07:15.365771007 +0000
-@@ -21,6 +21,7 @@
- #include <sys/sysinfo.h>
- #include <sys/ioctl.h>
- #include <sys/socket.h>
-+#include <sys/types.h>
- #include <linux/sockios.h>
- #include <linux/if.h>
- #include <linux/ethtool.h>
diff --git a/dev-lang/spidermonkey/files/spidermonkey-threadlocal.patch b/dev-lang/spidermonkey/files/spidermonkey-threadlocal.patch
deleted file mode 100644
index 3658c418..00000000
--- a/dev-lang/spidermonkey/files/spidermonkey-threadlocal.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fixes:
- Error relocating /usr/lib/libmozjs-52.so: _ZN2js16TlsPerThreadDataE: symbol not found
-
---- mozjs-52.9.1pre1/mfbt/ThreadLocal.h.orig 2018-11-28 09:48:43.746859132 +0000
-+++ mozjs-52.9.1pre1/mfbt/ThreadLocal.h 2018-11-28 09:48:45.930897382 +0000
-@@ -211,7 +211,7 @@
- }
-
- #ifdef MOZ_HAS_THREAD_LOCAL
--#define MOZ_THREAD_LOCAL(TYPE) __thread mozilla::detail::ThreadLocal<TYPE>
-+#define MOZ_THREAD_LOCAL(TYPE) MOZ_EXPORT __thread mozilla::detail::ThreadLocal<TYPE>
- #else
- #define MOZ_THREAD_LOCAL(TYPE) mozilla::detail::ThreadLocal<TYPE>
- #endif
diff --git a/dev-lang/spidermonkey/metadata.xml b/dev-lang/spidermonkey/metadata.xml
deleted file mode 100644
index 514b7f91..00000000
--- a/dev-lang/spidermonkey/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>mozilla@gentoo.org</email>
- <name>Gentoo Mozilla Team</name>
- </maintainer>
- <longdescription lang="en">
- Stand-alone JavaScript C++ library
- </longdescription>
- <use>
- <flag name="custom-optimization">Build with user-specified compiler optimizations
- (-Os, -O0, -O1, -O2, -O3) from CFLAGS (unsupported)</flag>
- <flag name="debug">Enable assertions to allow for easier debugging of programs that link to spidermonkey -- note this will often crash software on regular end-user systems</flag>
- <flag name="system-icu">Use the system-wide <pkg>dev-libs/icu</pkg> instead of bundled -- note, only takes effect when icu flag is enabled</flag>
- </use>
-</pkgmetadata>
diff --git a/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild b/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild
deleted file mode 100644
index 2db5ba57..00000000
--- a/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-WANT_AUTOCONF="2.1"
-inherit autotools toolchain-funcs pax-utils mozcoreconf-v5
-
-MY_PN="mozjs"
-MY_P="${MY_PN}-${PV/_rc/.rc}"
-MY_P="${MY_P/_pre/pre}"
-DESCRIPTION="Stand-alone JavaScript C++ library"
-HOMEPAGE="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
-#SRC_URI="https://people.mozilla.org/~sfink/${MY_P}.tar.bz2"
-SRC_URI="http://ftp.mozilla.org/pub/spidermonkey/prereleases/52/pre1/mozjs-52.9.1pre1.tar.bz2 -> ${MY_P}.tar.bz2
- https://dev.gentoo.org/~axs/distfiles/${PN}-52.0-patches-0.tar.xz"
-
-LICENSE="NPL-1.1"
-SLOT="52"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
-IUSE="debug elibc_musl minimal +system-icu test"
-
-RESTRICT="ia64? ( test )"
-
-S="${WORKDIR}/${MY_P%.rc*}"
-BUILDDIR="${S}/jsobj"
-
-RDEPEND=">=dev-libs/nspr-4.13.1
- virtual/libffi
- sys-libs/readline:0=
- >=sys-libs/zlib-1.2.3
- system-icu? ( >=dev-libs/icu-58.1:= )"
-DEPEND="${RDEPEND}"
-
-pkg_setup(){
- [[ ${MERGE_TYPE} == "binary" ]] || \
- moz_pkgsetup
-
- export SHELL="${EPREFIX}/bin/bash"
-}
-
-src_prepare() {
- # remove patches integrated by upstream
- rm -f "${WORKDIR}"/${PN}/0002-build-Add-major-version-to-make-parallel-installable.patch \
- "${WORKDIR}"/${PN}/0005-headers-Fix-symbols-visibility.patch \
- "${WORKDIR}"/${PN}/0007-build-Remove-unnecessary-NSPR-dependency.patch \
- "${WORKDIR}"/${PN}/0008-tests-Skip-on-all-64-bit-archs.patch \
- || die
-
- eapply "${WORKDIR}/${PN}"
- eapply "${FILESDIR}"/moz38-dont-hardcode-libc-soname.patch
- eapply "${FILESDIR}"/${PN}-52.0-fix-alpha-bitness.patch
- use elibc_musl && eapply "${FILESDIR}"/${PN}-musl.patch
- use elibc_musl && eapply "${FILESDIR}"/${PN}-threadlocal.patch
-
- eapply_user
-
- cd "${S}"/js/src || die
- eautoconf old-configure.in
- eautoconf
-
- # there is a default config.cache that messes everything up
- rm -f "${S}"/js/src/config.cache || die
-
- mkdir -p "${BUILDDIR}" || die
-}
-
-src_configure() {
- cd "${BUILDDIR}" || die
-
- ECONF_SOURCE="${S}/js/src" \
- econf \
- $(use_enable !elibc_musl jemalloc) \
- --enable-readline \
- --with-system-nspr \
- --disable-optimize \
- --with-intl-api \
- $(use_with system-icu) \
- $(use_enable debug) \
- $(use_enable test tests) \
- XARGS="/usr/bin/xargs" \
- SHELL="${SHELL:-${EPREFIX}/bin/bash}" \
- CC="${CC}" CXX="${CXX}" LD="${LD}" AR="${AR}" RANLIB="${RANLIB}"
-}
-
-cross_make() {
- emake \
- CFLAGS="${BUILD_CFLAGS}" \
- CXXFLAGS="${BUILD_CXXFLAGS}" \
- AR="${BUILD_AR}" \
- CC="${BUILD_CC}" \
- CXX="${BUILD_CXX}" \
- RANLIB="${BUILD_RANLIB}" \
- SHELL="${SHELL:-${EPREFIX}/bin/bash}" \
- "$@"
-}
-src_compile() {
- cd "${BUILDDIR}" || die
- if tc-is-cross-compiler; then
- tc-export_build_env BUILD_{AR,CC,CXX,RANLIB}
- cross_make \
- MOZ_OPTIMIZE_FLAGS="" MOZ_DEBUG_FLAGS="" \
- HOST_OPTIMIZE_FLAGS="" MODULE_OPTIMIZE_FLAGS="" \
- MOZ_PGO_OPTIMIZE_FLAGS="" \
- host_jsoplengen host_jskwgen
- cross_make \
- MOZ_OPTIMIZE_FLAGS="" MOZ_DEBUG_FLAGS="" HOST_OPTIMIZE_FLAGS="" \
- -C config nsinstall
- mv {,native-}host_jskwgen || die
- mv {,native-}host_jsoplengen || die
- mv config/{,native-}nsinstall || die
- sed -i \
- -e 's@./host_jskwgen@./native-host_jskwgen@' \
- -e 's@./host_jsoplengen@./native-host_jsoplengen@' \
- Makefile || die
- sed -i -e 's@/nsinstall@/native-nsinstall@' config/config.mk || die
- rm -f config/host_nsinstall.o \
- config/host_pathsub.o \
- host_jskwgen.o \
- host_jsoplengen.o || die
- fi
-
- MOZ_MAKE_FLAGS="${MAKEOPTS}" \
- SHELL="${SHELL:-${EPREFIX}/bin/bash}" \
- emake \
- MOZ_OPTIMIZE_FLAGS="" MOZ_DEBUG_FLAGS="" \
- HOST_OPTIMIZE_FLAGS="" MODULE_OPTIMIZE_FLAGS="" \
- MOZ_PGO_OPTIMIZE_FLAGS=""
-}
-
-src_test() {
- cd "${BUILDDIR}/js/src/jsapi-tests" || die
- ./jsapi-tests || die
-}
-
-src_install() {
- cd "${BUILDDIR}" || die
- SHELL="${SHELL:-${EPREFIX}/bin/bash}" \
- emake DESTDIR="${D}" install
-
- if ! use minimal; then
- pax-mark m "${ED}"usr/bin/js${SLOT}
- else
- rm -f "${ED}"usr/bin/js${SLOT}
- fi
-
- # We can't actually disable building of static libraries
- # They're used by the tests and in a few other places
- find "${D}" -iname '*.a' -o -iname '*.ajs' -delete || die
-}