aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-11 21:02:58 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-11 21:02:58 +0100
commita3bb64af91767057e64f3c5c60a3e4ed9e7b9ea0 (patch)
treeeaf6054af0c5d3a3f1e4efef959f1b91a516d09d
parentwww-client/firefox: Version 75.0b1 (diff)
downloadmozilla-a3bb64af91767057e64f3c5c60a3e4ed9e7b9ea0.tar.gz
mozilla-a3bb64af91767057e64f3c5c60a3e4ed9e7b9ea0.tar.bz2
mozilla-a3bb64af91767057e64f3c5c60a3e4ed9e7b9ea0.zip
www-client/firefox: synchronize with Gentoo repository
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-75.0_beta1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-75.0_beta1.ebuild b/www-client/firefox/firefox-75.0_beta1.ebuild
index 2240bdc5..445d1170 100644
--- a/www-client/firefox/firefox-75.0_beta1.ebuild
+++ b/www-client/firefox/firefox-75.0_beta1.ebuild
@@ -38,7 +38,7 @@ if [[ "${PV}" == *_rc* ]]; then
MOZ_SRC_URI="${MOZ_HTTP_URI}/source/${PN}-${MOZ_PV}.source.tar.xz -> $P.tar.xz"
fi
-LLVM_MAX_SLOT=9
+LLVM_MAX_SLOT=10
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
@@ -131,6 +131,15 @@ DEPEND="${CDEPEND}
sys-apps/findutils
|| (
(
+ sys-devel/clang:10
+ !clang? ( sys-devel/llvm:10 )
+ clang? (
+ =sys-devel/lld-10*
+ sys-devel/llvm:10[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-10*[profile] )
+ )
+ )
+ (
sys-devel/clang:9
!clang? ( sys-devel/llvm:9 )
clang? (
@@ -675,7 +684,7 @@ src_install() {
fi
# Install language packs
- MOZ_INSTALL_L10N_XPIFILE="1" mozlinguas_src_install
+ MOZEXTENSION_TARGET="distribution/extensions" MOZ_INSTALL_L10N_XPIFILE="1" mozlinguas_src_install
local size sizes icon_path icon name
if use bindist ; then