summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lisp/gsll/Manifest1
-rw-r--r--dev-lisp/gsll/gsll-9999.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-lisp/gsll/Manifest b/dev-lisp/gsll/Manifest
new file mode 100644
index 00000000..8dadd45f
--- /dev/null
+++ b/dev-lisp/gsll/Manifest
@@ -0,0 +1 @@
+EBUILD gsll-9999.ebuild 830 RMD160 075f8d5342f8873c1d23c63b5783c94d4261bdf0 SHA1 d77c6feb0b40d13864c55fc225bf0464361f6af5 SHA256 6f02cbb11ab1ac22db070bed769e5d75627df1069531f3c0a2a37c6537c88638
diff --git a/dev-lisp/gsll/gsll-9999.ebuild b/dev-lisp/gsll/gsll-9999.ebuild
new file mode 100644
index 00000000..a5efe41a
--- /dev/null
+++ b/dev-lisp/gsll/gsll-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EGIT_REPO_URI="git://repo.or.cz/gsll.git"
+
+inherit common-lisp-2 git
+
+DESCRIPTION="Common Lisp interface to the GNU Scientific Library."
+HOMEPAGE="http://common-lisp.net/project/gsll/"
+
+LICENSE="LLGPL-2.1 FDL"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=">=sci-libs/gsl-1.9
+ >=dev-lisp/cffi-0.10.0
+ dev-lisp/trivial-garbage
+ dev-lisp/cl-utilities"
+
+CLSYSTEMS="${PN} ${PN}-tests"
+
+src_install() {
+ common-lisp-install *.{lisp,asd} data/ floating-point/ histogram/ init/ \
+ interpolation/ linear-algebra/ ordinary-differential-equations/ \
+ random/ solve-minimize-fit/ special-functions/ statistics/ \
+ tests/ test-unit/
+ common-lisp-symlink-asdf
+ dohtml documentation/*.{html,css}
+ dodoc documentation/*.text
+}