summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Touceda <chiiph@gmail.com>2009-12-16 14:27:27 -0300
committerChema Alonso Josa <nimiux@gentoo.org>2018-03-09 22:27:26 +0100
commit91729aa8bbd7c989da84d1ed912b609541ee744c (patch)
treebeee131ff2d8254b9982c02d06ea1f05e3b99375
parentdev-lisp/common-lisp-controller: Fix broken Manifest and keywords (diff)
downloadlisp-91729aa8bbd7c989da84d1ed912b609541ee744c.tar.gz
lisp-91729aa8bbd7c989da84d1ed912b609541ee744c.tar.bz2
lisp-91729aa8bbd7c989da84d1ed912b609541ee744c.zip
Add lispbuilder-sdl{-gfx,-image}
-rw-r--r--dev-lisp/lispbuilder-sdl-gfx/Manifest2
-rw-r--r--dev-lisp/lispbuilder-sdl-gfx/lispbuilder-sdl-gfx-0.6.4.ebuild27
-rw-r--r--dev-lisp/lispbuilder-sdl-image/Manifest2
-rw-r--r--dev-lisp/lispbuilder-sdl-image/lispbuilder-sdl-image-0.4.2.ebuild25
-rw-r--r--dev-lisp/lispbuilder-sdl/Manifest2
-rw-r--r--dev-lisp/lispbuilder-sdl/lispbuilder-sdl-0.9.8.ebuild27
6 files changed, 85 insertions, 0 deletions
diff --git a/dev-lisp/lispbuilder-sdl-gfx/Manifest b/dev-lisp/lispbuilder-sdl-gfx/Manifest
new file mode 100644
index 00000000..3a845084
--- /dev/null
+++ b/dev-lisp/lispbuilder-sdl-gfx/Manifest
@@ -0,0 +1,2 @@
+DIST lispbuilder-sdl-gfx-0.6.4.tgz 37514 RMD160 2eb987b463e9f9618db73b08f006c2eada8dbdda SHA1 38a748ca8ba46eb79ec23e9ffcab9d8cc35c4240 SHA256 59287eb3d99269f436bc5e4102d99f6d1239b7ecc4c63dc801172ddaa9be8459
+EBUILD lispbuilder-sdl-gfx-0.6.4.ebuild 569 RMD160 b5247562cef5c438edbba4d79a51ef61586557dc SHA1 79df3ddd5810a76612e411b3eb44f6b8f10b8e5d SHA256 86216bb9ca2e3b688261c9ce0dc0ec06f30597ee0636b312e6af191464225ce8
diff --git a/dev-lisp/lispbuilder-sdl-gfx/lispbuilder-sdl-gfx-0.6.4.ebuild b/dev-lisp/lispbuilder-sdl-gfx/lispbuilder-sdl-gfx-0.6.4.ebuild
new file mode 100644
index 00000000..96d03e73
--- /dev/null
+++ b/dev-lisp/lispbuilder-sdl-gfx/lispbuilder-sdl-gfx-0.6.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit common-lisp-2
+
+DESCRIPTION="Lisp Application Builder Interface to libSDL"
+HOMEPAGE="http://code.google.com/p/lispbuilder/"
+SRC_URI="http://lispbuilder.googlecode.com/files/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+CLPACKAGE="lispbuilder-sdl-gfx"
+
+src_install() {
+ common-lisp-install *.asd bin/ cffi/ examples/ sdl-gfx/
+ common-lisp-symlink-asdf
+
+ dodoc documentation/README || die
+}
diff --git a/dev-lisp/lispbuilder-sdl-image/Manifest b/dev-lisp/lispbuilder-sdl-image/Manifest
new file mode 100644
index 00000000..b32c7e7f
--- /dev/null
+++ b/dev-lisp/lispbuilder-sdl-image/Manifest
@@ -0,0 +1,2 @@
+DIST lispbuilder-sdl-image-0.4.2.tgz 134639 RMD160 db14eaba73b7107d5881a05b973b2b17b2e21de6 SHA1 c5032f080b19c7cce83a82a7fb39c3fc305de7ec SHA256 07278fbf6a96dc718e379670baa7976826edf75b35938726a0b7e7e2521734af
+EBUILD lispbuilder-sdl-image-0.4.2.ebuild 537 RMD160 6db325199cf2a4c7bf384af1aa1c86a4b0047094 SHA1 eed381a5657fb1912987a11703df832c36a175c8 SHA256 0a6d897b62a3b71c76c58e639a0d8f3ba4e0b0df2cc26e079d79ff6d06d13a4c
diff --git a/dev-lisp/lispbuilder-sdl-image/lispbuilder-sdl-image-0.4.2.ebuild b/dev-lisp/lispbuilder-sdl-image/lispbuilder-sdl-image-0.4.2.ebuild
new file mode 100644
index 00000000..71b77e20
--- /dev/null
+++ b/dev-lisp/lispbuilder-sdl-image/lispbuilder-sdl-image-0.4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit common-lisp-2
+
+DESCRIPTION="Lisp Application Builder Interface to libSDL"
+HOMEPAGE="http://code.google.com/p/lispbuilder/"
+SRC_URI="http://lispbuilder.googlecode.com/files/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+CLPACKAGE="lispbuilder-sdl-image"
+
+src_install() {
+ common-lisp-install *.asd bin/ cffi/ examples/ sdl-image/
+ common-lisp-symlink-asdf
+}
diff --git a/dev-lisp/lispbuilder-sdl/Manifest b/dev-lisp/lispbuilder-sdl/Manifest
new file mode 100644
index 00000000..a8aa2e42
--- /dev/null
+++ b/dev-lisp/lispbuilder-sdl/Manifest
@@ -0,0 +1,2 @@
+DIST lispbuilder-sdl-0.9.8.tgz 347316 RMD160 100e546441dcfd351feb96e3a04e2a2ba53502ec SHA1 7afb4a2d1e0d4a8599e42a8ebe9fb9f89f9ebafc SHA256 e06e6301bc2fd4d220213cf83afbc24c6d2b93520090310d78258735ac4fea06
+EBUILD lispbuilder-sdl-0.9.8.ebuild 702 RMD160 aca1d813721014b7232d53ccbef87561f0158f1a SHA1 7db741146ff6cb9b9a20ce9d36c877820e6a58a1 SHA256 f5c5cd9446c0aad0a4da1684fcce88e3a1070a379201cbc73390c09f8eb8c889
diff --git a/dev-lisp/lispbuilder-sdl/lispbuilder-sdl-0.9.8.ebuild b/dev-lisp/lispbuilder-sdl/lispbuilder-sdl-0.9.8.ebuild
new file mode 100644
index 00000000..41717a61
--- /dev/null
+++ b/dev-lisp/lispbuilder-sdl/lispbuilder-sdl-0.9.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit common-lisp-2
+
+DESCRIPTION="Lisp Application Builder Interface to libSDL"
+HOMEPAGE="http://code.google.com/p/lispbuilder/"
+SRC_URI="http://lispbuilder.googlecode.com/files/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+DEPEND="media-libs/libsdl"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+CLPACKAGE="lispbuilder-sdl"
+
+src_install() {
+ common-lisp-install *.asd assets/ base/ \
+ bin/ cffi/ cocoahelper/ examples/ glue-cl-vectors \
+ glue-sdl/ glue-vecto/ sdl/ starter-pack/ trivial-garbage/
+ common-lisp-symlink-asdf
+ dohtml documentation/*.html documentation/*.png || die
+}