aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Eloe <powerofazure@gmail.com>2010-08-13 09:03:47 -0500
committerNathan Eloe <powerofazure@gmail.com>2010-08-13 11:21:46 -0500
commit308b7c249124a93417c599d5a79140c4ef188949 (patch)
tree10bf47e3d97cbe3531ead420c0f141014f07777d /configure.ac
parentUpdate to .gitignore (diff)
downloadlibbash-308b7c249124a93417c599d5a79140c4ef188949.tar.gz
libbash-308b7c249124a93417c599d5a79140c4ef188949.tar.bz2
libbash-308b7c249124a93417c599d5a79140c4ef188949.zip
Build system for coding style
Adds rules to the build system to generate the build system Adds a check to configure.ac for pdflatex Build coding standard by running make coding_standard.pdf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d43c01a..728550f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,10 @@ else
AC_CHECK_FILE(["$with_antlr"],[],[AC_MSG_ERROR(Antlr jar $with_antlr not found)])
AC_SUBST(antlr_cp,["$with_antlr"])
fi
+AC_PATH_PROG([PDFLATEX],[pdflatex],"no")
+if test "$PDFLATEX" = "no"; then
+ AC_MSG_RESULT([pdflatex not found on your system. You will be unable to generate the coding standard])
+fi
AC_CHECK_LIB([antlr3c],[antlr3AsciiFileStreamNew],[],[AC_MSG_ERROR(libasntlr3c not found. Have you installed the C antlr runtime?)])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT