aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-06-22 22:03:36 +0800
committerMu Qiao <qiaomuf@gentoo.org>2011-06-22 23:03:31 +0800
commitc3e341ad6dbb9efbed40cf29a0013defe938c5c6 (patch)
treeac87e3291b8c3404aee92c71b4961c3681deb7c8 /Makefile.am
parentWalker: first support for brace expansion (diff)
downloadlibbash-c3e341ad6dbb9efbed40cf29a0013defe938c5c6.tar.gz
libbash-c3e341ad6dbb9efbed40cf29a0013defe938c5c6.tar.bz2
libbash-c3e341ad6dbb9efbed40cf29a0013defe938c5c6.zip
Core: add more exceptions
We don't want to use only one exception everywhere. Now more exceptions are added to improve the exception hierarchy.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a706c43..85f7761 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -205,7 +205,14 @@ libcppbash_la_SOURCES = src/common.h \
src/builtins/builtin_exceptions.h \
$(GENERATED_PARSER_C) \
$(GENERATED_PARSER_H) \
+ src/core/divide_by_zero_error.h \
+ src/core/exceptions.h \
+ src/core/illegal_argument_exception.h \
src/core/interpreter_exception.h \
+ src/core/parse_exception.h \
+ src/core/readonly_exception.h \
+ src/core/runtime_exception.h \
+ src/core/unsupported_exception.h \
src/core/unset_exception.h \
src/core/interpreter.cpp \
src/core/interpreter.h \