aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <petsku@petteriraty.eu>2011-05-12 15:05:06 +0300
committerPetteri Räty <petsku@petteriraty.eu>2011-05-12 17:03:26 +0300
commit1999c27e98093985aa4cf7778b4681c362b95de9 (patch)
tree3766e124d17a37e02891a1d862a9a4809f763d0e /Makefile.am
parentWalker: first support for extended pattern matching (diff)
downloadlibbash-1999c27e98093985aa4cf7778b4681c362b95de9.tar.gz
libbash-1999c27e98093985aa4cf7778b4681c362b95de9.tar.bz2
libbash-1999c27e98093985aa4cf7778b4681c362b95de9.zip
Build: silence javac warnings
The antlr generated sources are for 1.4 so add -source 1.4 to AM_JAVACFLAGS to suppress warnings about unchecked or unsafe operations.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bb36f72..33387ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -71,7 +71,7 @@ EBUILD_RESULT = scripts/sunpinyin-2.0.3-r1.ebuild.result
TESTS = $(GUNIT_TESTS) $(BASH_TESTS) $(EBUILD_TESTS)
# these get cleaned so only add autogenerated stuff or modify CLEANFILES
check_JAVA = bashast/bashastLexer.java bashast/bashastParser.java
-AM_JAVACFLAGS = -classpath @antlr_cp@
+AM_JAVACFLAGS = -source 1.4 -classpath @antlr_cp@
COMMON_FLAGS = -std=c++0x -I$(top_srcdir)/src/
# We use -x c++ to compile all C source files as C++ because there's C++