aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-20 10:30:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-20 11:14:22 +0100
commit963a927dccd1c6b1dad77910f9b389fb28774e62 (patch)
tree87d4c72c9e79c35e619091122f8a485aec6e13c8 /kde-plasma/plasma-firewall
parentkde-plasma/plasma-disks: 5.26.90 version bump (diff)
downloadkde-963a927dccd1c6b1dad77910f9b389fb28774e62.tar.gz
kde-963a927dccd1c6b1dad77910f9b389fb28774e62.tar.bz2
kde-963a927dccd1c6b1dad77910f9b389fb28774e62.zip
kde-plasma/plasma-firewall: 5.26.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-5.26.90.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
new file mode 100644
index 0000000000..922e55c5fc
--- /dev/null
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -0,0 +1 @@
+DIST plasma-firewall-5.26.90.tar.xz 361920 BLAKE2B b432338c5b64462527f3a72f7fe742a196de64a7f082d8b2afed4cf71e44e22450cf814c1ea802b14f6552ace5e08c93fd1d9fcc9bb6c5f2397272580d190ac2 SHA512 1c2aa823914add54ddd1e57d14442a670964b086abfb5698776e5c48c93e6a7cd4be29d6c625e1254977aa835cbc1c9eceb1a697a38868da9beffa2426319d87
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-5.26.90.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-5.26.90.ebuild
new file mode 100644
index 0000000000..a2e0e8a0e5
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-5.26.90.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{9..11} )
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}