aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-13 18:12:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-13 18:55:04 +0200
commit8e7c37fd838ba2312cccbf34f802e70a814107d3 (patch)
tree2ee4bf3da9c853d8f414b1020a30de090292e642 /kde-plasma/plasma-firewall
parentkde-plasma/plasma-disks: 6.1.0 version bump (diff)
downloadkde-8e7c37fd838ba2312cccbf34f802e70a814107d3.tar.gz
kde-8e7c37fd838ba2312cccbf34f802e70a814107d3.tar.bz2
kde-8e7c37fd838ba2312cccbf34f802e70a814107d3.zip
kde-plasma/plasma-firewall: 6.1.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-6.1.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
new file mode 100644
index 0000000000..5abb697256
--- /dev/null
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -0,0 +1 @@
+DIST plasma-firewall-6.1.0.tar.xz 372628 BLAKE2B e2ce183f927213c21148e3c758ecccb175484dad79767509efbcf289551156cf895974ae11f73ebe4015e30da090489b29ff720852d0001ae1614e429a57da5e SHA512 00b8db564a4ae18a6524495238f8206a066afe944e846cea8b794ab603f4ef7401762ae06cf176a23ed10df8e772cf6033697b10894888c0462adb815fed163d
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-6.1.0.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-6.1.0.ebuild
new file mode 100644
index 0000000000..f39457cf39
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-6.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{10..12} )
+KFMIN=6.3.0
+QTMIN=6.7.1
+inherit ecm plasma.kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,xml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}