aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-17 05:53:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-17 05:53:41 +0100
commite990105b6f203517fad24f14af323b018a0c1ca4 (patch)
tree07b47aac8e05e041ccfb573742eee91f4d76a4e2 /kde-apps/knights
parentkde5.eclass: HOMEPAGE: Fix www.kde.org to kde.org redirection (diff)
downloadkde-e990105b6f203517fad24f14af323b018a0c1ca4.tar.gz
kde-e990105b6f203517fad24f14af323b018a0c1ca4.tar.bz2
kde-e990105b6f203517fad24f14af323b018a0c1ca4.zip
kde-apps: Add KDE Applications 19.04 stable branch
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/knights')
-rw-r--r--kde-apps/knights/knights-19.04.49.9999.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/kde-apps/knights/knights-19.04.49.9999.ebuild b/kde-apps/knights/knights-19.04.49.9999.ebuild
new file mode 100644
index 0000000000..7e5dadf4bf
--- /dev/null
+++ b/kde-apps/knights/knights-19.04.49.9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_SELINUX_MODULE="games"
+inherit kde5
+
+DESCRIPTION="Simple chess board based on KDE Frameworks"
+HOMEPAGE="https://kde.org/applications/games/knights/"
+
+LICENSE="GPL-2+"
+KEYWORDS=""
+IUSE="speech"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kplotting)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_kdeapps_dep libkdegames)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}
+ || (
+ games-board/gnuchess
+ games-board/crafty
+ games-board/stockfish
+ games-board/sjeng
+ )
+"