aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-11-18 19:51:23 +1100
committerMichael Palimaka <kensington@gentoo.org>2014-11-24 23:05:28 +1100
commit6c61e006354ccbe86157239ab44f68dfedc86643 (patch)
tree3fa0f755ce4945210f3cb91e8a875c6fce62eb73 /kde-apps/analitza/analitza-9999.ebuild
parent[profiles] Add kde-apps category. (diff)
downloadkde-6c61e006354ccbe86157239ab44f68dfedc86643.tar.gz
kde-6c61e006354ccbe86157239ab44f68dfedc86643.tar.bz2
kde-6c61e006354ccbe86157239ab44f68dfedc86643.zip
Introduce KDE Applications.
All packages which have a KDE Applications release have moved from kde-base to kde-apps. 9999 is back, and is upstream master (whether it be KDE 4 or KF5). For packages with an unreleased KF5 branch, 5.9999 is used.
Diffstat (limited to 'kde-apps/analitza/analitza-9999.ebuild')
-rw-r--r--kde-apps/analitza/analitza-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-apps/analitza/analitza-9999.ebuild b/kde-apps/analitza/analitza-9999.ebuild
new file mode 100644
index 0000000000..bf5100628c
--- /dev/null
+++ b/kde-apps/analitza/analitza-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KDE_HANDBOOK="never"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE library for mathematical features"
+KEYWORDS=""
+IUSE="debug readline"
+
+DEPEND="
+ opengl? ( virtual/glu )
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with readline)
+ )
+
+ kde4-base_src_configure
+}