aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-30 22:08:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-30 22:57:37 +0200
commit6f20beb9eeb4fa249078b98262c6aaac69546549 (patch)
tree412a18e1a72188ce4470d515cabdb7ae91905945 /app-office/kexi/kexi-9999.ebuild
parentkde-plasma/plasma-vault: Backport use networkmanager (diff)
downloadkde-6f20beb9eeb4fa249078b98262c6aaac69546549.tar.gz
kde-6f20beb9eeb4fa249078b98262c6aaac69546549.tar.bz2
kde-6f20beb9eeb4fa249078b98262c6aaac69546549.zip
app-office/kexi: Fix cmake warning
Closes: https://bugs.gentoo.org/659644 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-office/kexi/kexi-9999.ebuild')
-rw-r--r--app-office/kexi/kexi-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-office/kexi/kexi-9999.ebuild b/app-office/kexi/kexi-9999.ebuild
index 2a8bea7335..a524f44ca2 100644
--- a/app-office/kexi/kexi-9999.ebuild
+++ b/app-office/kexi/kexi-9999.ebuild
@@ -73,7 +73,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DKEXI_MIGRATEMANAGER_DEBUG=$(usex debug)
- -DKEXI_SCRIPTING_DEBUG=$(usex debug)
-DKEXI_AUTORISE_TABBED_TOOLBAR=$(usex experimental)
-DKEXI_SCRIPTS_SUPPORT=$(usex experimental)
$(cmake-utils_use_find_package marble KexiMarble)
@@ -81,5 +80,7 @@ src_configure() {
$(cmake-utils_use_find_package mysql MySQL)
$(cmake-utils_use_find_package postgres PostgreSQL)
)
+ use experimental && mycmakeargs+=( -DKEXI_SCRIPTING_DEBUG=$(usex debug) )
+
kde5_src_configure
}