aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-06-04 17:53:01 -0400
committerMike Gilbert <floppym@gentoo.org>2015-06-04 17:53:01 -0400
commite4f1310d07f9dc4acc005586d278f9d592f00b48 (patch)
treefa1d7f957431cc44d4fa70c27a6e8caae76940cf /Makefile
parentsystemd is now officially hosted on github (diff)
downloadhwids-e4f1310d07f9dc4acc005586d278f9d592f00b48.tar.gz
hwids-e4f1310d07f9dc4acc005586d278f9d592f00b48.tar.bz2
hwids-e4f1310d07f9dc4acc005586d278f9d592f00b48.zip
Processs udev files with a for loop
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 6c79b3e..1e84ea5 100644
--- a/Makefile
+++ b/Makefile
@@ -32,6 +32,9 @@ INSTALL_TARGETS-yes = install-base
INSTALL_TARGETS-$(UDEV) += install-hwdb
SYSTEMD_SOURCE = https://github.com/systemd/systemd/raw/master/hwdb
+UDEV_FILES = 20-acpi-vendor.hwdb 20-bluetooth-vendor-product.hwdb
+UDEV_FILES += 20-net-ifname.hwdb 60-keyboard.hwdb 70-mouse.hwdb
+UDEV_FILES += 70-pointingstick.hwdb 70-touchpad.hwdb
all: $(ALL_TARGETS-yes)
@@ -43,14 +46,8 @@ fetch:
$(Q)curl -z oui.txt -o oui.txt -R http://standards-oui.ieee.org/oui.txt
$(Q)curl -z iab.txt -o iab.txt -R http://standards.ieee.org/develop/regauth/iab/iab.txt
$(Q)curl -L -z sdio.ids -o sdio.ids -R $(SYSTEMD_SOURCE)/sdio.ids
- $(Q)curl -L -z udev/20-acpi-vendor.hwdb -o udev/20-acpi-vendor.hwdb -R $(SYSTEMD_SOURCE)/20-acpi-vendor.hwdb
- $(Q)curl -L -z udev/20-bluetooth-vendor-product.hwdb -o udev/20-bluetooth-vendor-product.hwdb -R $(SYSTEMD_SOURCE)/20-bluetooth-vendor-product.hwdb
- $(Q)curl -L -z udev/20-net-ifname.hwdb -o udev/20-net-ifname.hwdb -R $(SYSTEMD_SOURCE)/20-net-ifname.hwdb
- $(Q)curl -L -z udev/60-keyboard.hwdb -o udev/60-keyboard.hwdb -R $(SYSTEMD_SOURCE)/60-keyboard.hwdb
- $(Q)curl -L -z udev/70-mouse.hwdb -o udev/70-mouse.hwdb -R $(SYSTEMD_SOURCE)/70-mouse.hwdb
- $(Q)curl -L -z udev/70-pointingstick.hwdb -o udev/70-pointingstick.hwdb -R $(SYSTEMD_SOURCE)/70-pointingstick.hwdb
- $(Q)curl -L -z udev/70-touchpad.hwdb -o udev/70-touchpad.hwdb -R $(SYSTEMD_SOURCE)/70-touchpad.hwdb
$(Q)curl -L -z udev-hwdb-update.pl -o udev-hwdb-update.pl -R $(SYSTEMD_SOURCE)/ids-update.pl
+ $(Q)for f in $(UDEV_FILES); do curl -L -z udev/$$f -o udev/$$f -R $(SYSTEMD_SOURCE)/$$f; done
$(Q)$(STATUS)
PV ?= $(shell ( awk '$$2 == "Date:" { print $$3; nextfile }' pci.ids usb.ids; git log --format=format:%ci -1 -- oui.txt udev/20-acpi-vendor.hwdb udev/20-bluetooth-vendor-product.hwdb udev/20-net-ifname.hwdb udev/60-keyboard.hwdb udev/70-mouse.hwdb udev/70-pointingstick.hwdb udev/70-touchpad.hwdb udev-hwdb-update.pl | cut -d ' ' -f1; ) | sort | tail -n 1 | tr -d -)