aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gcc-4.5.0/piepatch/12_all_gcc45_Makefile.in.patch')
-rw-r--r--gcc-4.5.0/piepatch/12_all_gcc45_Makefile.in.patch200
1 files changed, 200 insertions, 0 deletions
diff --git a/gcc-4.5.0/piepatch/12_all_gcc45_Makefile.in.patch b/gcc-4.5.0/piepatch/12_all_gcc45_Makefile.in.patch
new file mode 100644
index 0000000..6ed15bf
--- /dev/null
+++ b/gcc-4.5.0/piepatch/12_all_gcc45_Makefile.in.patch
@@ -0,0 +1,200 @@
+2009-09-20 Magnus Granberg <zorry@gentoo.org> Anthony G. Basile <basile@opensource.dyc.edu>
+
+ * Makefile.in We add -fno-stack-protector to
+ BOOT_CFLAGS, LIBCFLAGS and LIBCXXFLAGS if enable_esp yes.
+ * gcc/Makefile.in Add -fno-PIE and -fno-stack-protector.
+ Libgcc2 doesn't compile with -fstack-protector.
+ Crtstuff doesn't compile with -fPIE and -fstack-protector.
+ Add crtbeginTS.o to EXTRA_PARTS if enable_crtbeginTS yes
+ We add new file crtbeginTS.o if enable_crtbeginTS yes
+ * libgcc/Makefile.in Add crtbeginTS.o to EXTRA_PARTS if enable_crtbeginTS yes
+ We add new file crtbeginTS.o if enable_crtbeginTS yes
+
+2009-07-21 Magnus Granberg <zorry@ume.nu>, Kees Cook <kees@outflux.net>
+
+ LP #344502
+ * libmudflap/Makefiles.in Add -fno-stack-protector -U_FORTIFY_SOURCE
+ to AM_CFLAGS if enable_esp yes.
+
+--- Makefile.in 2010-01-22 08:35:38.000000000 -0500
++++ Makefile.in 2010-02-07 15:10:59.000000000 -0500
+@@ -350,9 +350,17 @@
+ BUILD_PREFIX = @BUILD_PREFIX@
+ BUILD_PREFIX_1 = @BUILD_PREFIX_1@
+
++# Some stuff don't compile with SSP
++enable_esp = @enable_esp@
++ifeq ($(enable_esp),yes)
++ESP_NOSSP_CFLAGS = -fno-stack-protector
++else
++ESP_NOSSP_CFLAGS=
++endif
++
+ # Flags to pass to stage2 and later makes. They are defined
+ # here so that they can be overridden by Makefile fragments.
+-BOOT_CFLAGS= -g -O2
++BOOT_CFLAGS= -g -O2 $(ESP_NOSSP_CFLAGS)
+ BOOT_LDFLAGS=
+ BOOT_ADAFLAGS=-gnatpg -gnata
+
+@@ -397,9 +405,9 @@
+
+ CFLAGS = @CFLAGS@
+ LDFLAGS = @LDFLAGS@
+-LIBCFLAGS = $(CFLAGS)
++LIBCFLAGS = $(CFLAGS) $(ESP_NOSSP_CFLAGS)
+ CXXFLAGS = @CXXFLAGS@
+-LIBCXXFLAGS = $(CXXFLAGS) -fno-implicit-templates
++LIBCXXFLAGS = $(CXXFLAGS) -fno-implicit-templates $(ESP_NOSSP_CFLAGS)
+
+ TFLAGS =
+
+--- gcc/Makefile.in 2010-01-22 17:22:51.000000000 -0500
++++ gcc/Makefile.in 2010-02-07 15:15:13.000000000 -0500
+@@ -629,13 +629,24 @@
+ INHIBIT_LIBC_CFLAGS = -Dinhibit_libc
+ endif
+
++# We don't want __stack_chk_fail in crt* and libgcc2.a.
++# We don't want to compile crtbegin, crtend and crtbeginT with -fPIE.
++enable_esp = @enable_esp@
++ifeq ($(enable_esp),yes)
++ESP_NOPIE_CFLAGS = -fno-PIE
++ESP_NOSSP_CFLAGS = -fno-stack-protector
++else
++ESP_NOPIE_CFLAGS=
++ESP_NOSSP_CFLAGS=
++endif
++
+ # Options to use when compiling libgcc2.a.
+ #
+ LIBGCC2_DEBUG_CFLAGS = -g
+ LIBGCC2_CFLAGS = -O2 $(LIBGCC2_INCLUDES) $(GCC_CFLAGS) $(TARGET_LIBGCC2_CFLAGS) \
+ $(LIBGCC2_DEBUG_CFLAGS) $(GTHREAD_FLAGS) \
+ -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED \
+- $(INHIBIT_LIBC_CFLAGS)
++ $(INHIBIT_LIBC_CFLAGS) $(ESP_NOSSP_CFLAGS)
+
+ # Additional options to use when compiling libgcc2.a.
+ # Some targets override this to -isystem include
+@@ -648,7 +659,7 @@
+ CRTSTUFF_CFLAGS = -O2 $(GCC_CFLAGS) $(INCLUDES) $(MULTILIB_CFLAGS) -g0 \
+ -finhibit-size-directive -fno-inline -fno-exceptions \
+ -fno-zero-initialized-in-bss -fno-toplevel-reorder -fno-tree-vectorize \
+- $(INHIBIT_LIBC_CFLAGS)
++ $(INHIBIT_LIBC_CFLAGS) $(ESP_NOSSP_CFLAGS)
+
+ # Additional sources to handle exceptions; overridden by targets as needed.
+ LIB2ADDEH = $(srcdir)/unwind-dw2.c $(srcdir)/unwind-dw2-fde.c \
+@@ -678,6 +689,12 @@
+ # The rules for compiling them should be in the t-* file for the machine.
+ EXTRA_PARTS = @extra_parts@
+
++# We add crtbeginTS.o to the EXTRA_PARTS list if enable_crtbeginTS = yes
++enable_crtbeginTS = @enable_crtbeginTS@
++ifeq ($(enable_crtbeginTS),yes)
++EXTRA_PARTS += crtbeginTS.o
++endif
++
+ # List of extra object files that should be compiled and linked with
+ # compiler proper (cc1, cc1obj, cc1plus).
+ EXTRA_OBJS = @extra_objs@
+@@ -1856,9 +1873,10 @@
+ echo LIBGCC_SYNC = '$(LIBGCC_SYNC)' >> tmp-libgcc.mvars
+ echo LIBGCC_SYNC_CFLAGS = '$(LIBGCC_SYNC_CFLAGS)' >> tmp-libgcc.mvars
+ echo CRTSTUFF_CFLAGS = '$(CRTSTUFF_CFLAGS)' >> tmp-libgcc.mvars
+- echo CRTSTUFF_T_CFLAGS = '$(CRTSTUFF_T_CFLAGS)' >> tmp-libgcc.mvars
++ echo CRTSTUFF_T_CFLAGS = '$(CRTSTUFF_T_CFLAGS) $(ESP_NOPIE_CFLAGS)' >> tmp-libgcc.mvars
+ echo CRTSTUFF_T_CFLAGS_S = '$(CRTSTUFF_T_CFLAGS_S)' >> tmp-libgcc.mvars
+ echo TARGET_SYSTEM_ROOT = '$(TARGET_SYSTEM_ROOT)' >> tmp-libgcc.mvars
++ echo enable_crtbeginTS = '$(enable_crtbeginTS)' >> tmp-libgcc.mvars
+
+ mv tmp-libgcc.mvars libgcc.mvars
+
+@@ -1892,12 +1910,14 @@
+ $(T)crtbegin.o: crtstuff.c $(GCC_PASSES) $(TCONFIG_H) auto-host.h \
+ gbl-ctors.h stmp-int-hdrs tsystem.h coretypes.h $(TM_H)
+ $(GCC_FOR_TARGET) $(CRTSTUFF_CFLAGS) $(CRTSTUFF_T_CFLAGS) \
++ $(ESP_NOPIE_CFLAGS) \
+ -c $(srcdir)/crtstuff.c -DCRT_BEGIN \
+ -o $(T)crtbegin$(objext)
+
+ $(T)crtend.o: crtstuff.c $(GCC_PASSES) $(TCONFIG_H) auto-host.h \
+ gbl-ctors.h stmp-int-hdrs tsystem.h coretypes.h $(TM_H)
+ $(GCC_FOR_TARGET) $(CRTSTUFF_CFLAGS) $(CRTSTUFF_T_CFLAGS) \
++ $(ESP_NOPIE_CFLAGS) \
+ -c $(srcdir)/crtstuff.c -DCRT_END \
+ -o $(T)crtend$(objext)
+
+@@ -1918,9 +1938,19 @@
+ $(T)crtbeginT.o: crtstuff.c $(GCC_PASSES) $(TCONFIG_H) auto-host.h \
+ gbl-ctors.h stmp-int-hdrs tsystem.h coretypes.h $(TM_H)
+ $(GCC_FOR_TARGET) $(CRTSTUFF_CFLAGS) $(CRTSTUFF_T_CFLAGS) \
++ $(ESP_NOPIE_CFLAGS) \
+ -c $(srcdir)/crtstuff.c -DCRT_BEGIN -DCRTSTUFFT_O \
+ -o $(T)crtbeginT$(objext)
+
++# This is a version of crtbegin for -static -fPIE links if esp is enable.
++ifeq ($(enable_crtbeginTS),yes)
++$(T)crtbeginTS.o: crtstuff.c $(GCC_PASSES) $(TCONFIG_H) auto-host.h \
++ gbl-ctors.h stmp-int-hdrs tsystem.h coretypes.h $(TM_H)
++ $(GCC_FOR_TARGET) $(CRTSTUFF_CFLAGS) $(CRTSTUFF_T_CFLAGS_S) \
++ -c $(srcdir)/crtstuff.c -DCRT_BEGIN -DCRTSTUFFT_O -DCRTSTUFFS_O \
++ -o $(T)crtbeginTS$(objext)
++endif
++
+ # Compile the start modules crt0.o and mcrt0.o that are linked with
+ # every program
+ $(T)crt0.o: s-crt0 ; @true
+--- libgcc/Makefile.in 2009-07-30 18:33:49.000000000 -0400
++++ libgcc/Makefile.in 2010-02-07 15:10:59.000000000 -0500
+@@ -291,6 +291,12 @@
+ gen-hide-list = echo > \$@
+ endif
+
++# We add crtbeginTS.o to the EXTRA_PARTS list if enable_crtbeginTS = yes
++enable_libgcc_crtbeginTS = $(enable_crtbeginTS)
++ifeq ($(enable_libgcc_crtbeginTS),yes)
++EXTRA_PARTS += crtbeginTS.o
++endif
++
+ ifneq ($(EXTRA_PARTS),)
+ extra-parts = libgcc-extra-parts
+ INSTALL_PARTS = $(EXTRA_PARTS)
+@@ -842,6 +848,13 @@
+ crtbeginT.o: $(gcc_srcdir)/crtstuff.c
+ $(crt_compile) $(CRTSTUFF_T_CFLAGS) \
+ -c $(gcc_srcdir)/crtstuff.c -DCRT_BEGIN -DCRTSTUFFT_O
++
++# This is a version of crtbegin for -static -fPIE links.
++ifeq ($(enable_libgcc_crtbeginTS),yes)
++crtbeginTS.o: $(gcc_srcdir)/crtstuff.c
++ $(crt_compile) $(CRTSTUFF_T_CFLAGS_S) \
++ -c $(gcc_srcdir)/crtstuff.c -DCRT_BEGIN -DCRTSTUFFT_O -DCRTSTUFFS_O
++endif
+ endif
+
+ # Build extra startfiles in the libgcc directory.
+--- libmudflap/Makefile.in 2009-12-05 12:18:53.000000000 -0500
++++ libmudflap/Makefile.in 2010-02-07 15:10:59.000000000 -0500
+@@ -304,10 +304,18 @@
+ MAINT_CHARSET = latin1
+ SUBDIRS = testsuite
+
++# Some stuff don't compile with PIE or SSP
++enable_esp = @enable_esp@
++ifeq ($(enable_esp),yes)
++NO_ESP_CFLAGS = -fno-stack-protector -U_FORTIFY_SOURCE
++else
++NO_ESP_CFLAGS =
++endif
++
+ # May be used by various substitution variables.
+ gcc_version := $(shell cat $(top_srcdir)/../gcc/BASE-VER)
+-AM_CFLAGS = -Wall $(SECTION_FLAGS)
+-@LIBMUDFLAPTH_FALSE@libmudflapth =
++AM_CFLAGS = -Wall $(SECTION_FLAGS) $(NO_ESP_CFLAGS)
++@LIBMUDFLAPTH_FALSE@libmudflapth =
+ @LIBMUDFLAPTH_TRUE@libmudflapth = libmudflapth.la
+ toolexeclib_LTLIBRARIES = libmudflap.la $(libmudflapth)
+ libsubincludedir = $(libdir)/gcc/$(target_noncanonical)/$(gcc_version)/include