summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-01 09:31:24 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-01 09:31:24 +0000
commit4ddf4fe5644583f32b5d4532b47d5feed9039a12 (patch)
treecc2bb4f649e5612bd91d9ef2330b04184dcd67a6
parentmerged from overlay 70:159, prefixified (diff)
downloadprefix-4ddf4fe5644583f32b5d4532b47d5feed9039a12.tar.gz
prefix-4ddf4fe5644583f32b5d4532b47d5feed9039a12.tar.bz2
prefix-4ddf4fe5644583f32b5d4532b47d5feed9039a12.zip
merged from overlay 26:159, eprefixified
(Portage 2.2.00.7521-prefix/SVN/Linux 2.6.20-1.2925.fc6 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+) svn path=/prefix-overlay/; revision=170
-rw-r--r--gnustep-libs/camaelon/Manifest8
-rw-r--r--gnustep-libs/camaelon/camaelon-0.2.ebuild25
-rw-r--r--gnustep-libs/camaelon/camaelon-2.0_pre20070504.ebuild32
-rw-r--r--gnustep-libs/camaelon/files/config-camaelon.sh4
4 files changed, 30 insertions, 39 deletions
diff --git a/gnustep-libs/camaelon/Manifest b/gnustep-libs/camaelon/Manifest
index 6f448cd..c80267a 100644
--- a/gnustep-libs/camaelon/Manifest
+++ b/gnustep-libs/camaelon/Manifest
@@ -1,5 +1,3 @@
-AUX config-camaelon.sh 352 RMD160 c96d3bf786dd9098eab8525d607c62e2516bd025 SHA1 edc55f83d1d49c641afc011f1ec79ca561988f52 SHA256 fd4e8bec4e1b02d4157f0e3ea2effb23515480aa41a399e5c7443dc444be7375
-DIST IndustrialTheme.tar.bz2 49338 RMD160 794adb1bd117e038a1211c33bb9740cd1ca9be9c SHA1 b61abb20b5cfdd56851c8f102d5f0779c7f29110 SHA256 29f9c2d0599a7ca84682e406eca2a546479c8cad386f19969ba437731e2b1379
-DIST MaxCurve-0.2.tar.bz2 48965 RMD160 29b910b8d1696633727f33bd1a8de11b21b56365 SHA1 5afaa87019821949b1df0ac1e21f79a645bbce8e SHA256 808b872ba00c02616b6d9754acb1533cd9139da88c22954506d236517d0b7202
-DIST camaelon-2.0_pre20070504.tar.bz2 106158 RMD160 ec6efdfe22ffd68af56da636f80e17ffba21b1bf SHA1 69cc8285a9596a9007835a3d468d4d931f181b43 SHA256 f1ddd9a51978e9b106cb4b90d9fe6a992f4b61bfeb3eeb49defff7981d1f848b
-EBUILD camaelon-2.0_pre20070504.ebuild 1127 RMD160 22ab95a28ffa24ae5ad9f47ab0c71b8c7493ce0d SHA1 5ea97b4c703144eccc50853a211b54ea7ae1374c SHA256 fe0e9f2763fa70e478222c3b45c2cf9b65378df155c3df8cc042938c4bba1d18
+AUX config-camaelon.sh 356 RMD160 c75a5e35cc0393b9988c2928c57acd15d0864f6c SHA1 725014a66ad2336f76fea89b2a6e37b102dcfee2 SHA256 f5fa31d210c040f2a04101a59817befb5983f6163d10b3b7bdb0fb436e55f6e2
+DIST etoile-0.2.tar.gz 21233211 RMD160 340add5114d6bd2ba9d6da648ec041702a09d565 SHA1 9d384114f5ac317eebcc6b5cda3a0f5898a7c1c7 SHA256 e3a016ceaeb28c02b9a7ac71db51ced38c0dc0fc36c8b539d878b826f988ae0f
+EBUILD camaelon-0.2.ebuild 705 RMD160 a80beb7447ddf0760ca5349202c22d56b41c9e26 SHA1 48069721bf29a25792101df9bca93ab79e528c12 SHA256 15f9d0e9e7dfd2c487664cb97f8a2958bba8e7f394aa944e51bfb351b42fb396
diff --git a/gnustep-libs/camaelon/camaelon-0.2.ebuild b/gnustep-libs/camaelon/camaelon-0.2.ebuild
new file mode 100644
index 0000000..c075d7f
--- /dev/null
+++ b/gnustep-libs/camaelon/camaelon-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="prefix"
+
+inherit gnustep-2
+
+S="${WORKDIR}/Etoile-${PV}/Bundles/${PN/c/C}"
+
+DESCRIPTION="Camaelon allows you to load theme bundles for GNUstep."
+
+HOMEPAGE="http://www.etoile-project.org/etoile/mediawiki/index.php?title=Camaelon"
+SRC_URI="http://download.gna.org/etoile/etoile-${PV}.tar.gz"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+src_install() {
+ gnustep-base_src_install
+
+ #Link default theme
+ mkdir -p ${D}${GNUSTEP_SYSTEM_LIBRARY}/Themes
+ ln -s ${GNUSTEP_SYSTEM_LIBRARY}/Bundles/Camaelon.themeEngine/Resources/Nesedah.theme ${D}${GNUSTEP_SYSTEM_LIBRARY}/Themes/
+}
diff --git a/gnustep-libs/camaelon/camaelon-2.0_pre20070504.ebuild b/gnustep-libs/camaelon/camaelon-2.0_pre20070504.ebuild
deleted file mode 100644
index eb04ef4..0000000
--- a/gnustep-libs/camaelon/camaelon-2.0_pre20070504.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/camaelon/camaelon-2.0_pre20060324.ebuild,v 1.1 2006/03/26 10:49:57 grobian Exp $
-
-inherit gnustep-2
-
-S=${WORKDIR}/${PN/c/C}
-
-DESCRIPTION="Camaelon allows you to load theme bundles for GNUstep."
-
-HOMEPAGE="http://www.etoile-project.org/etoile/mediawiki/index.php?title=Camaelon"
-SRC_URI="http://overlays.gentoo.org/svn/proj/gnustep/downloads/${P}.tar.bz2
- http://brante.dyndns.org/gnustep/download/MaxCurve-0.2.tar.bz2
- mirror://sourceforge/mpdcon/IndustrialTheme.tar.bz2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
-SLOT="0"
-LICENSE="LGPL-2.1"
-
-IUSE=""
-DEPEND="${GS_DEPEND}"
-RDEPEND="${GS_RDEPEND}"
-
-egnustep_install_domain "System"
-
-src_install() {
- gnustep-2_src_install || die "install failed"
-
- #install themes (and link default one)
- mkdir -p ${D}${GNUSTEP_SYSTEM_LIBRARY}/Themes
- cp -R ${WORKDIR}/*theme ${D}${GNUSTEP_SYSTEM_LIBRARY}/Themes/
- ln -s ${GNUSTEP_SYSTEM_LIBRARY}/Bundles/Camaelon.themeEngine/Resources/Nesedah.theme ${D}${GNUSTEP_SYSTEM_LIBRARY}/Themes/
-}
diff --git a/gnustep-libs/camaelon/files/config-camaelon.sh b/gnustep-libs/camaelon/files/config-camaelon.sh
index ca692aa..ee3c519 100644
--- a/gnustep-libs/camaelon/files/config-camaelon.sh
+++ b/gnustep-libs/camaelon/files/config-camaelon.sh
@@ -1,5 +1,5 @@
echo "Applying Camaelon default theme..."
-echo "defaults write NSGlobalDomain GSAppKitUserBundles \"(${GNUSTEP_SYSTEM_LIBRARY}/Bundles/Camaelon.themeEngine)\""
-defaults write NSGlobalDomain GSAppKitUserBundles "(${GNUSTEP_SYSTEM_LIBRARY}/Bundles/Camaelon.themeEngine)"
+echo "defaults write NSGlobalDomain GSAppKitUserBundles \"(/usr/GNUstep/System/Library/Bundles/Camaelon.themeEngine)\""
+defaults write NSGlobalDomain GSAppKitUserBundles "(/usr/GNUstep/System/Library/Bundles/Camaelon.themeEngine)"
echo "defaults write Camaelon Theme Nesedah"
defaults write Camaelon Theme Nesedah