summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-12 16:54:08 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-21 15:20:06 +0200
commit30fa150f55a0aa5a14302abc12a345d6560c90da (patch)
tree66a0482cc74f18c1c1e695366b5589f0fe352fa8 /net-libs/gnome-online-accounts
parentwww-client/epiphany: 3.10.3 → 3.12.0 (diff)
downloadgnome-30fa150f55a0aa5a14302abc12a345d6560c90da.tar.gz
gnome-30fa150f55a0aa5a14302abc12a345d6560c90da.tar.bz2
gnome-30fa150f55a0aa5a14302abc12a345d6560c90da.zip
net-libs/gnome-online-accounts: 3.10.4 → 3.12.0
Not adding a USE for webkit inspector since this seems dedicated to development and debugging.
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest11
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.12.0.ebuild76
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild5
3 files changed, 90 insertions, 2 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
new file mode 100644
index 00000000..c76a7c5a
--- /dev/null
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-online-accounts-3.12.0.tar.xz 1286904 SHA256 81d44afb3b993b7fb465d19b1b572db423bc7591e309f829d0639c802d7dfcc2 SHA512 0a803e4c76b916c31b0e390be349d72b4fdcf2ed1c8d92bb4a1214f2cc85b1983e54c519c7a1bc87815c849f7adef4aa9d4ad02f8fe2dab37f39ccded471055e WHIRLPOOL 1fb295feda9cafe01bbea693e468b07d834abe4393c7987433b12d63101a726d81c0200d6c115ca9c5700bcb7fb7bebaf9c6c16e80715faac5dd7aabb18576b3
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNJU5EACgkQ1fmVwcYIWAac7gCgwpO9is16haeUBtZRXbNWaQ2c
+YRYAoIauJV2t0FIfQtpsbRYfCeJRA7l3
+=AOLN
+-----END PGP SIGNATURE-----
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.12.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.12.0.ebuild
new file mode 100644
index 00000000..652f4d8c
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.12.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+IUSE="gnome +introspection kerberos" # telepathy"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.35:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.1.90:3
+ >=x11-libs/gtk+-3.11.1:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ kerberos? (
+ app-crypt/gcr:0=
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_configure() {
+ # TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
+ # Twitter/Y! disabled per upstream recommendation, bug #497168
+ # telepathy optional support is really badly done, bug #494456
+ gnome2_src_configure \
+ --disable-static \
+ --disable-twitter \
+ --disable-yahoo \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-imap-smtp \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ $(use_enable kerberos)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
index c7562349..0749f635 100644
--- a/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} = 9999 ]]; then
fi
DESCRIPTION="GNOME framework for accessing online accounts"
-HOMEPAGE="https://wiki.gnome.org/GnomeOnlineAccounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
LICENSE="LGPL-2+"
SLOT="0/1"
@@ -37,7 +37,7 @@ RDEPEND="
net-libs/rest:0.7
net-libs/telepathy-glib
>=net-libs/webkit-gtk-2.1.90:3
- >=x11-libs/gtk+-3.5.1:3
+ >=x11-libs/gtk+-3.11.1:3
x11-libs/pango
introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
@@ -80,6 +80,7 @@ src_configure() {
--enable-flickr \
--enable-imap-smtp \
--enable-owncloud \
+ --enable-pocket \
--enable-telepathy \
$(use_enable kerberos)
#$(use_enable telepathy)