summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-04 23:18:01 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-04 23:24:07 +0200
commitf7a6fca81bc5d47d59092f01c6178fa48ad8f7f5 (patch)
tree8757ad577fbcf11d8e7141d22cce76c02c3df54b /net-analyzer
parentmedia-sound/sound-juicer: bump to 2.28.0 (diff)
downloadgnome-f7a6fca81bc5d47d59092f01c6178fa48ad8f7f5.tar.gz
gnome-f7a6fca81bc5d47d59092f01c6178fa48ad8f7f5.tar.bz2
gnome-f7a6fca81bc5d47d59092f01c6178fa48ad8f7f5.zip
net-analyzer/gnome-nettool: bump to 2.28.0
2.28.0 - #576221: Fix glibtop initialization order in order to make it work on BSD (Joe Marcus Clarke) - #583286: Compilation fixes for DragonFly BSD (Thomas Klausner) - #577788: Made some tooltips translatable (Gabor Kelemen) - #503587: Avoid freeze in whois tab when encoding isn't the expected one (Antonio Litterio) - #583286: Fix compilation for DragonFly BSD (Thomas Klausner) - #580149: Use GtkBuilder instead of libglade (Jaap A. Haitsma)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/gnome-nettool/Manifest2
-rw-r--r--net-analyzer/gnome-nettool/gnome-nettool-2.28.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/gnome-nettool/Manifest b/net-analyzer/gnome-nettool/Manifest
new file mode 100644
index 00000000..2d55ac1a
--- /dev/null
+++ b/net-analyzer/gnome-nettool/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-nettool-2.28.0.tar.bz2 641475 RMD160 0c466faf79137022b19cac21d3231ca7805d58e9 SHA1 5f734227e4cccbfd3d9bb29193b862eaa4e47ccf SHA256 ecce19920e2bf5b7cac8ffd26d8592adff7b895d1ee219b18a84a46313f36dd5
+EBUILD gnome-nettool-2.28.0.ebuild 1412 RMD160 2ae2c67eda33bb9d5efa50557ae8c91fc642efac SHA1 1ca976f7ebccfaca8621159f52ccef1f43f96e71 SHA256 41781eedcddb98ebad98c226e2b888ac78ea0649b56671c118f1d1f9ec51c5e9
diff --git a/net-analyzer/gnome-nettool/gnome-nettool-2.28.0.ebuild b/net-analyzer/gnome-nettool/gnome-nettool-2.28.0.ebuild
new file mode 100644
index 00000000..eaf216ce
--- /dev/null
+++ b/net-analyzer/gnome-nettool/gnome-nettool-2.28.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnome-nettool/gnome-nettool-2.26.2.ebuild,v 1.2 2009/05/28 22:02:01 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Collection of network tools"
+HOMEPAGE="http://www.gnome.org/projects/gnome-network/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.12:2
+ >=gnome-base/gconf-2
+ gnome-base/libgtop:2"
+RDEPEND="${COMMON_DEPEND}
+ || ( net-analyzer/traceroute sys-freebsd/freebsd-usbin )
+ net-dns/bind-tools
+ userland_GNU? ( net-misc/netkit-fingerd net-misc/whois )
+ userland_BSD? ( net-misc/bsdwhois )"
+
+# Gilles Dartiguelongue <eva@gentoo.org> (12 Apr 2008)
+# Mask gnome-system-tools 2.14 because it is starting to cause more headache
+# to keep it than to mask it.
+# Support is autodetected at runtime anyway.
+# app-admin/gnome-system-tools
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ app-text/gnome-doc-utils"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ --disable-scrollkeeper"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}