summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gtkparasite/gtkparasite-9999.ebuild')
-rw-r--r--x11-plugins/gtkparasite/gtkparasite-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/x11-plugins/gtkparasite/gtkparasite-9999.ebuild b/x11-plugins/gtkparasite/gtkparasite-9999.ebuild
index 92443ea..d1c6b0a 100644
--- a/x11-plugins/gtkparasite/gtkparasite-9999.ebuild
+++ b/x11-plugins/gtkparasite/gtkparasite-9999.ebuild
@@ -2,23 +2,28 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit git
+inherit autotools base git
DESCRIPTION="Parasite is a GTK+ debugger"
HOMEPAGE="http://chipx86.github.com/gtkparasite/"
EGIT_REPO_URI="git://github.com/chipx86/gtkparasite"
-EGIT_BOOTSTRAP="./autogen.sh --help"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=x11-libs/gtk+-2.12.0
- >=dev-python/pygtk-2.10.3"
-RDEPEND="${DEPEND}"
+# FIXME: python support is automagic
+RDEPEND=">=x11-libs/gtk+-2.12.0
+ >=dev-python/pygtk-2.10.3"
+DEPEND="${RDEPEND}"
+
+# All of these are currently empty
+#DOCS="AUTHORS ChangeLog NEWS README"
src_unpack() {
git_src_unpack
-}
+ cd "${S}"
+ eautoreconf
+}