summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/NetworkManager/NetworkManager-9999.ebuild')
-rw-r--r--net-misc/NetworkManager/NetworkManager-9999.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/NetworkManager/NetworkManager-9999.ebuild b/net-misc/NetworkManager/NetworkManager-9999.ebuild
new file mode 100644
index 0000000..d55daeb
--- /dev/null
+++ b/net-misc/NetworkManager/NetworkManager-9999.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools gnome2 eutils gnome2-live
+
+DESCRIPTION="Network configuration and management in an easy way. Desktop environment independent."
+HOMEPAGE="http://www.gnome.org/projects/NetworkManager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc gnutls"
+
+PROVIDE="net-misc/networkmanager"
+# Yes, I know that configure will accept libnl 1.0-pre8, however we only have
+# 1.1 in the tree, therefore dep on it.
+RDEPEND=">=dev-libs/glib-2.10
+ >=dev-libs/dbus-glib-0.75
+ >=sys-apps/dbus-0.60
+ >=sys-apps/hal-0.5.10
+ >=dev-libs/libnl-1.1
+ >=net-wireless/wireless-tools-28_pre9
+ net-dialup/ppp
+ gnutls? ( >=net-libs/gnutls-1.2 )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ !net-misc/networkmanager"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+USE_DESTDIR="1"
+PATCHES="${PN}-confchanges.patch
+ ${PN}-initscript-changes.patch"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-more-warnings
+ --without-resolvconf
+ --localstatedir=/var
+ --with-distro=gentoo
+ --with-resolvconf=/etc/resolv.conf
+ --with-dbus-sys-dir=/etc/dbus-1/system.d"
+
+ if use gnutls; then
+ G2CONF="${G2CONF} --with-crypto=gnutls"
+ else
+ G2CONF="${G2CONF} --with-crypto=nss"
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+ # Need to keep the /var/run/NetworkManager directory
+ keepdir /var/run/NetworkManager
+}
+
+pkg_postinst() {
+ elog "You need to be in the plugdev group in order to use NetworkManager"
+ elog "Problems with your hostname getting changed?"
+ elog ""
+ elog "Add the following to /etc/dhcp/dhclient.conf"
+ elog 'send host-name "YOURHOSTNAME";'
+ elog 'supersede host-name "YOURHOSTNAME";'
+
+ elog "You will need to restart DBUS if this is your first time"
+ elog "installing NetworkManager."
+}