aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bin')
-rwxr-xr-xbin/ebump2
-rwxr-xr-xbin/euse2
-rw-r--r--bin/meson.build55
-rwxr-xr-xbin/revdep-rebuild.sh2
4 files changed, 58 insertions, 3 deletions
diff --git a/bin/ebump b/bin/ebump
index 25e9a7c..dc045e7 100755
--- a/bin/ebump
+++ b/bin/ebump
@@ -12,7 +12,7 @@ __description__="Ebuild version bumping tool"
# a given ebuild and auxiliary files in the Portage tree. It is only
# useful for Gentoo developers with CVS commit access.
-VERSION="git"
+VERSION="@VERSION@"
die() {
echo $1 >&2
diff --git a/bin/euse b/bin/euse
index daffd66..f15a36c 100755
--- a/bin/euse
+++ b/bin/euse
@@ -8,7 +8,7 @@ set -f
# Licensed under the GPL v2
PROGRAM_NAME=euse
-VERSION="git"
+VERSION="@VERSION@"
EPREFIX=${EPREFIX:-$(portageq envvar EPREFIX)}
ETC="${EPREFIX}/etc"
diff --git a/bin/meson.build b/bin/meson.build
new file mode 100644
index 0000000..eb99870
--- /dev/null
+++ b/bin/meson.build
@@ -0,0 +1,55 @@
+py_bins = [
+ 'eclean',
+ 'eclean-dist',
+ 'eclean-pkg',
+ 'ekeyword',
+ 'enalyze',
+ 'epkginfo',
+ 'equery',
+ 'eread',
+ 'eshowkw',
+ 'imlate',
+ 'merge-driver-ekeyword',
+ 'revdep-rebuild',
+]
+
+ebump = configure_file(
+ input : 'ebump',
+ output : 'ebump',
+ configuration : conf_data
+)
+
+euse = configure_file(
+ input : 'euse',
+ output : 'euse',
+ configuration : conf_data
+)
+
+revdep_rebuild_sh = configure_file(
+ input : 'revdep-rebuild.sh',
+ output : 'revdep-rebuild.sh',
+ configuration : conf_data
+)
+
+other_bins = [
+ ebump,
+ euse,
+ revdep_rebuild_sh,
+]
+
+# It might seem sensible to use py.install_sources() to install the Python
+# scripts, but it's really just a wrapper around install_data that forces the
+# install_dir. Meson 1.2.0 and later also optimize to bytecode, but Gentoo does
+# this in the ebuild.
+
+install_data(
+ py_bins,
+ install_dir : get_option('bindir'),
+ install_mode : 'rwxr-xr-x',
+)
+
+install_data(
+ other_bins,
+ install_dir : get_option('bindir'),
+ install_mode : 'rwxr-xr-x',
+)
diff --git a/bin/revdep-rebuild.sh b/bin/revdep-rebuild.sh
index 09b0d1c..457b0f2 100755
--- a/bin/revdep-rebuild.sh
+++ b/bin/revdep-rebuild.sh
@@ -18,7 +18,7 @@ unset GREP_OPTIONS
# Readonly variables:
declare -r APP_NAME="revdep-rebuild" # # The name of this application
-declare -r VERSION="git"
+declare -r VERSION="@VERSION@"
declare -r OIFS="$IFS" # Save the IFS
declare -r ENV_FILE=0_env.rr # Contains environment variables
declare -r FILES_FILE=1_files.rr # Contains a list of files to search