summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-04-13 05:31:40 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-06-17 13:35:01 -0400
commit12e879989fe8090dd588f9c7b824e4183dcbd01f (patch)
tree1d84250237c7b95764b5780219a0cf52a024ac18 /media-gfx
parentapp-arch/engrampa: Version bump to 1.12.0, add 9999, add gtk3 (diff)
downloadgentoo-mate-12e879989fe8090dd588f9c7b824e4183dcbd01f.tar.gz
gentoo-mate-12e879989fe8090dd588f9c7b824e4183dcbd01f.tar.bz2
gentoo-mate-12e879989fe8090dd588f9c7b824e4183dcbd01f.zip
media-gfx/eom: Version bump to 1.12.2, add 9999, add gtk3
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eom/Manifest1
-rw-r--r--media-gfx/eom/eom-1.12.2.ebuild81
-rw-r--r--media-gfx/eom/eom-9999.ebuild81
-rw-r--r--media-gfx/eom/metadata.xml3
4 files changed, 166 insertions, 0 deletions
diff --git a/media-gfx/eom/Manifest b/media-gfx/eom/Manifest
index bdc0126..4f064fb 100644
--- a/media-gfx/eom/Manifest
+++ b/media-gfx/eom/Manifest
@@ -1 +1,2 @@
DIST eom-1.10.5.tar.xz 2207424 SHA256 19b484dba1c2adf1450153815e4edb05ba7ab7bdf4eb8b4f2071766e48e72d14 SHA512 f58f2c4c1d211afe66c2a112b75ee6b325590294da51df3a56d1dca0fb813cea1abd9e9dc7a4a3f26c111f1c11aba20e8177e36913f04bae664f4ddad6f98c0c WHIRLPOOL 1ce95839628e51060f2c77e8a701046754817870f998a6388aa620e12470b2e690e11edd5e7770303da33103f0077a3726eba01bd537a2cc3729bbd29dbc92d0
+DIST eom-1.12.2.tar.xz 2213260 SHA256 38ad10a6794e02e9e319a293393a36532e86572010442ba2f1d3773313c0a1da SHA512 03283cb1cae817c7c21219913fe2f3ab64e0fa6662a63193d4fa012bd0b5c286cbd25131a5bd5e52c1d9304b4b10ae8c37d38a88ea985215c5b277303d7b8cc4 WHIRLPOOL ad1745e5a0b223b96f715488b36c9c96a6b0f439a5ace02f06c2e05d09c6260bbf29c6d103fb40adfbbe6140d5a981f954185b04d0065b90b5f71625eec7783c
diff --git a/media-gfx/eom/eom-1.12.2.ebuild b/media-gfx/eom/eom-1.12.2.ebuild
new file mode 100644
index 0000000..3e2cc8a
--- /dev/null
+++ b/media-gfx/eom/eom-1.12.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="The MATE image viewer"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="X debug dbus exif gtk3 +introspection jpeg lcms python svg tiff xmp"
+
+REQUIRED_USE="
+ gtk3? ( !python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ "
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2:2
+ gnome-base/dconf:0
+ >=mate-base/mate-desktop-1.9.1[gtk3(-)=]
+ sys-libs/zlib:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.4:2[introspection?,jpeg?,tiff?]
+ x11-libs/libX11:0
+ >=x11-misc/shared-mime-info-0.20:0
+ virtual/libintl:0
+ dbus? ( >=dev-libs/dbus-glib-0.71:0 )
+ exif? (
+ >=media-libs/libexif-0.6.14:0
+ virtual/jpeg:0
+ )
+ !gtk3? ( >=x11-libs/gtk+-2.18:2[introspection?] )
+ gtk3? ( >=x11-libs/gtk+-3.0:3[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.15.1:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.13:2[${PYTHON_USEDEP}]
+ )
+ svg? ( >=gnome-base/librsvg-2.36.2:2 )
+ xmp? ( >=media-libs/exempi-1.99.5:2 )
+ !!media-gfx/mate-image-viewer"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_with X x) \
+ $(use_with dbus) \
+ $(use_with exif libexif) \
+ $(use_with jpeg libjpeg) \
+ $(use_with lcms cms) \
+ $(use_with svg librsvg) \
+ $(use_with xmp)
+}
diff --git a/media-gfx/eom/eom-9999.ebuild b/media-gfx/eom/eom-9999.ebuild
new file mode 100644
index 0000000..3e2cc8a
--- /dev/null
+++ b/media-gfx/eom/eom-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="The MATE image viewer"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="X debug dbus exif gtk3 +introspection jpeg lcms python svg tiff xmp"
+
+REQUIRED_USE="
+ gtk3? ( !python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ "
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2:2
+ gnome-base/dconf:0
+ >=mate-base/mate-desktop-1.9.1[gtk3(-)=]
+ sys-libs/zlib:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.4:2[introspection?,jpeg?,tiff?]
+ x11-libs/libX11:0
+ >=x11-misc/shared-mime-info-0.20:0
+ virtual/libintl:0
+ dbus? ( >=dev-libs/dbus-glib-0.71:0 )
+ exif? (
+ >=media-libs/libexif-0.6.14:0
+ virtual/jpeg:0
+ )
+ !gtk3? ( >=x11-libs/gtk+-2.18:2[introspection?] )
+ gtk3? ( >=x11-libs/gtk+-3.0:3[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.15.1:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.13:2[${PYTHON_USEDEP}]
+ )
+ svg? ( >=gnome-base/librsvg-2.36.2:2 )
+ xmp? ( >=media-libs/exempi-1.99.5:2 )
+ !!media-gfx/mate-image-viewer"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_with X x) \
+ $(use_with dbus) \
+ $(use_with exif libexif) \
+ $(use_with jpeg libjpeg) \
+ $(use_with lcms cms) \
+ $(use_with svg librsvg) \
+ $(use_with xmp)
+}
diff --git a/media-gfx/eom/metadata.xml b/media-gfx/eom/metadata.xml
index 519571d..1309b01 100644
--- a/media-gfx/eom/metadata.xml
+++ b/media-gfx/eom/metadata.xml
@@ -5,6 +5,9 @@
<email>mate@gentoo.org</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
+ <use>
+ <flag name="gtk3">Build with GTK+3 instead of GTK+2</flag>
+ </use>
<upstream>
<remote-id type="github">mate-desktop/eom</remote-id>
</upstream>