summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta SATOH <nigoro.dev@gmail.com>2016-09-30 20:31:17 +0900
committerYuta SATOH <nigoro.dev@gmail.com>2016-09-30 20:31:17 +0900
commit0893d9fcb292ceef2bebe61005ee0e73c517344c (patch)
tree3e043eb7f4d4eec24aa2ab725cdc8de65f23711a /sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch
parentsys-freebsd/freebsd-sources: drop ${PN}-7.1-types.h-fix.patch (diff)
downloadgentoo-bsd-0893d9fcb292ceef2bebe61005ee0e73c517344c.tar.gz
gentoo-bsd-0893d9fcb292ceef2bebe61005ee0e73c517344c.tar.bz2
gentoo-bsd-0893d9fcb292ceef2bebe61005ee0e73c517344c.zip
sys-freebsd: boot0 can build with gcc.
Diffstat (limited to 'sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch')
-rw-r--r--sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch b/sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch
new file mode 100644
index 0000000..c7a69d6
--- /dev/null
+++ b/sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch
@@ -0,0 +1,21 @@
+diff --git a/sys/boot/efi/Makefile b/sys/boot/efi/Makefile
+index 79ee9a9..f7789f1 100644
+--- a/sys/boot/efi/Makefile
++++ b/sys/boot/efi/Makefile
+@@ -4,7 +4,7 @@
+
+ # In-tree GCC does not support __attribute__((ms_abi)), but gcc newer
+ # than 4.5 supports it.
+-.if ${COMPILER_TYPE} != "gcc" || ${COMPILER_VERSION} >= 404500
++.if ${COMPILER_TYPE} != "gcc" || ${COMPILER_VERSION} >= 40500
+
+ .if ${MACHINE_CPUARCH} == "aarch64" || ${MACHINE_CPUARCH} == "arm"
+ .if ${MK_FDT} != "no"
+@@ -18,6 +18,6 @@ SUBDIR+= fdt
+ SUBDIR+= libefi loader boot1
+ .endif
+
+-.endif # ${COMPILER_TYPE} != "gcc" || ${COMPILER_VERSION} >= 404500
++.endif # ${COMPILER_TYPE} != "gcc" || ${COMPILER_VERSION} >= 40500
+
+ .include <bsd.subdir.mk>