aboutsummaryrefslogtreecommitdiff
path: root/11.3.0
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-22 02:17:39 +0100
committerSam James <sam@gentoo.org>2022-08-22 02:41:31 +0100
commit776eb259d04acdd0bbc24a606f08b72b61c2c653 (patch)
tree79cc70964ffa98f1b73d29f246e74495c08523bf /11.3.0
parent11.3.0: add 77_all_glibc_236.patch (diff)
downloadgcc-patches-776eb259d04acdd0bbc24a606f08b72b61c2c653.tar.gz
gcc-patches-776eb259d04acdd0bbc24a606f08b72b61c2c653.tar.bz2
gcc-patches-776eb259d04acdd0bbc24a606f08b72b61c2c653.zip
11.3.0: fix 20_all_libstdcxx-no-vtv.patch, update 77_all_glibc_236.patch
- fix 20_all_libstdcxx-no-vtv.patch (accidentally copied 11.4.0 patch before) - update 77_all_glibc_236.patch to contain Go fix too Bug: https://bugs.gentoo.org/865879 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to '11.3.0')
-rw-r--r--11.3.0/gentoo/20_all_libstdcxx-no-vtv.patch24
-rw-r--r--11.3.0/gentoo/77_all_glibc_236.patch29
-rw-r--r--11.3.0/gentoo/README.history2
3 files changed, 42 insertions, 13 deletions
diff --git a/11.3.0/gentoo/20_all_libstdcxx-no-vtv.patch b/11.3.0/gentoo/20_all_libstdcxx-no-vtv.patch
index 2719e2d..68508bd 100644
--- a/11.3.0/gentoo/20_all_libstdcxx-no-vtv.patch
+++ b/11.3.0/gentoo/20_all_libstdcxx-no-vtv.patch
@@ -5,27 +5,27 @@ Bug: https://bugs.gentoo.org/582524
Bug: https://gcc.gnu.org/PR85884
--- a/libstdc++-v3/src/Makefile.am
+++ b/libstdc++-v3/src/Makefile.am
-@@ -277,7 +277,6 @@ CXXLINK = \
+@@ -217,7 +217,6 @@ CXXLINK = \
$(LIBTOOL) --tag CXX \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
- $(VTV_CXXLINKFLAGS) \
- $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) \
- $(LTLDFLAGS) $(LTLIBICONV) \
- -o $@
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+
+ # Symbol versioning for shared libraries.
--- a/libstdc++-v3/src/Makefile.in
+++ b/libstdc++-v3/src/Makefile.in
-@@ -642,7 +642,6 @@ CXXLINK = \
+@@ -511,7 +511,6 @@ CXXLINK = \
$(LIBTOOL) --tag CXX \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
- $(VTV_CXXLINKFLAGS) \
- $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) \
- $(LTLDFLAGS) $(LTLIBICONV) \
- -o $@
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+
+ @ENABLE_SYMVERS_TRUE@CLEANFILES = libstdc++-symbols.ver $(version_dep)
--- a/libstdc++-v3/src/c++11/Makefile.am
+++ b/libstdc++-v3/src/c++11/Makefile.am
-@@ -214,5 +214,4 @@ CXXLINK = \
+@@ -204,5 +204,4 @@ CXXLINK = \
$(LIBTOOL) --tag CXX --tag disable-shared \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
@@ -33,7 +33,7 @@ Bug: https://gcc.gnu.org/PR85884
$(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
--- a/libstdc++-v3/src/c++11/Makefile.in
+++ b/libstdc++-v3/src/c++11/Makefile.in
-@@ -588,7 +588,6 @@ CXXLINK = \
+@@ -496,7 +496,6 @@ CXXLINK = \
$(LIBTOOL) --tag CXX --tag disable-shared \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
@@ -43,7 +43,7 @@ Bug: https://gcc.gnu.org/PR85884
all: all-am
--- a/libstdc++-v3/src/c++98/Makefile.am
+++ b/libstdc++-v3/src/c++98/Makefile.am
-@@ -268,5 +268,4 @@ CXXLINK = \
+@@ -273,5 +273,4 @@ CXXLINK = \
$(LIBTOOL) --tag CXX --tag disable-shared \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
@@ -51,7 +51,7 @@ Bug: https://gcc.gnu.org/PR85884
$(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
--- a/libstdc++-v3/src/c++98/Makefile.in
+++ b/libstdc++-v3/src/c++98/Makefile.in
-@@ -590,7 +590,6 @@ CXXLINK = \
+@@ -500,7 +500,6 @@ CXXLINK = \
$(LIBTOOL) --tag CXX --tag disable-shared \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
diff --git a/11.3.0/gentoo/77_all_glibc_236.patch b/11.3.0/gentoo/77_all_glibc_236.patch
index c74e6ac..b398ec4 100644
--- a/11.3.0/gentoo/77_all_glibc_236.patch
+++ b/11.3.0/gentoo/77_all_glibc_236.patch
@@ -1,4 +1,6 @@
https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=d2356ebb0084a0d80dbfe33040c9afe938c15d19
+https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=a55184ada8e2887ca94c0ab07027617885beafc9
+https://bugs.gentoo.org/865879
Fix build w/ glibc 2.36.
@@ -37,3 +39,30 @@ Subject: [PATCH] libsanitizer: cherry-pick 9cf13067cb5088626ba7 from upstream
unsigned IOCTL_GIO_CMAP = GIO_CMAP;
unsigned IOCTL_GIO_FONT = GIO_FONT;
unsigned IOCTL_GIO_UNIMAP = GIO_UNIMAP;
+
+From a55184ada8e2887ca94c0ab07027617885beafc9 Mon Sep 17 00:00:00 2001
+From: Ian Lance Taylor <iant@golang.org>
+Date: Tue, 12 Jul 2022 19:42:43 -0700
+Subject: [PATCH] libgo: don't include <linux/fs.h> when building
+ gen-sysinfo.go
+
+Removing this doesn't change anything at least with glibc 2.33.
+The include was added in https://go.dev/cl/6100049 but it's not
+clear why.
+
+Fixes PR go/106266
+
+Reviewed-on: https://go-review.googlesource.com/c/gofrontend/+/417294
+(cherry picked from commit f35d65517a59565758107c5b1a51a5fa382f8d1a)
+--- a/libgo/sysinfo.c
++++ b/libgo/sysinfo.c
+@@ -158,9 +158,6 @@
+ #if defined(HAVE_LINUX_ETHER_H)
+ #include <linux/ether.h>
+ #endif
+-#if defined(HAVE_LINUX_FS_H)
+-#include <linux/fs.h>
+-#endif
+ #if defined(HAVE_LINUX_REBOOT_H)
+ #include <linux/reboot.h>
+ #endif
diff --git a/11.3.0/gentoo/README.history b/11.3.0/gentoo/README.history
index 11d3a12..44c3d49 100644
--- a/11.3.0/gentoo/README.history
+++ b/11.3.0/gentoo/README.history
@@ -1,4 +1,4 @@
-6 18 August 2022
+6 22 August 2022
+ 77_all_glibc_236.patch
5 3 July 2022