summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 14:57:11 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 14:57:11 +0300
commit8a40ce4fe1bde66e8446c8be71f420ad13b1c179 (patch)
tree86c81941ffd922ef76f6e43ffa8d92a38a29acf9 /games-puzzle
parentgames-puzzle/spacechem: update package (diff)
downloadgamerlay-8a40ce4fe1bde66e8446c8be71f420ad13b1c179.tar.gz
gamerlay-8a40ce4fe1bde66e8446c8be71f420ad13b1c179.tar.bz2
gamerlay-8a40ce4fe1bde66e8446c8be71f420ad13b1c179.zip
games-puzzle/spirits: update package
Migrated from deprecated eclass. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/spirits/metadata.xml11
-rw-r--r--games-puzzle/spirits/spirits-1.0.1-r1.ebuild (renamed from games-puzzle/spirits/spirits-1.0.1.ebuild)31
2 files changed, 25 insertions, 17 deletions
diff --git a/games-puzzle/spirits/metadata.xml b/games-puzzle/spirits/metadata.xml
new file mode 100644
index 0000000..aec4945
--- /dev/null
+++ b/games-puzzle/spirits/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>mva@mva.name</email>
+<name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/games-puzzle/spirits/spirits-1.0.1.ebuild b/games-puzzle/spirits/spirits-1.0.1-r1.ebuild
index ffec38b..489e434 100644
--- a/games-puzzle/spirits/spirits-1.0.1.ebuild
+++ b/games-puzzle/spirits/spirits-1.0.1-r1.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: games-puzzle/kinetris/kinetris-1.0.0b_pre5.ebuild frostwork Exp $
-EAPI="5"
+EAPI=7
MY_PN="Spirits"
-inherit games
+inherit desktop eutils
DESCRIPTION="Save the spirits of leaf litters"
HOMEPAGE="http://www.spacesofplay.com/spirits/"
SRC_URI="${PN}-linux-${PV}_120903-1348705231.zip"
-LICENSE="as-is"
+LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
@@ -26,16 +25,16 @@ S="${WORKDIR}/${MY_PN}"
src_install() {
local libdir binary
- GAMEDIR="${GAMES_PREFIX_OPT}/${MY_PN}"
+ local dir="/opt/${MY_PN}"
use amd64 && {
-# TODO: unbundling SDL2
+ # TODO: unbundling SDL2
libdir=x86_64
binary=Spirits-64
}
use x86 && {
-# TODO: unbundling SDL2
+ # TODO: unbundling SDL2
libdir=i686
binary=Spirits-32
}
@@ -44,21 +43,19 @@ src_install() {
rm "./${libdir}/libopenal.so.1"
- exeinto "${GAMEDIR}"
- insinto "${GAMEDIR}"
+ exeinto "${dir}"
+ insinto "${dir}"
doins -r data
-# TODO: unbundling SDL2
+ # TODO: unbundling SDL2
doins -r "${libdir}"
doexe "${binary}"
- # install shortcuts
- games_make_wrapper "${PN}" "./${binary}" "${GAMEDIR}" "${GAMEDIR}/${libdir}" || die "install shortcut"
- make_desktop_entry "${PN}" "${MY_PN}" "${PN}"
-
- prepgamesdirs
+ # install shortcuts
+ make_wrapper "${PN}" "./${binary}" "${dir}" "${dir}/${libdir}" || die "install shortcut"
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}"
}
pkg_postinstall() {
einfo "If pre-start dialog looks ugly for you, try to remove ~/.themes"
einfo "At least, it helped me in such situation."
-} \ No newline at end of file
+}