summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2013-07-24 23:20:04 +0400
committerVadim A. Misbakh-Soloviov <mva@mva.name>2013-07-24 23:20:04 +0400
commit52c72083cbcfdec331934e35afa70f46467e550f (patch)
tree5f4ab26618a58a2cd505805e1cea9ebebf8017a0 /games-arcade/rush
parent[games-strategy/openxcom] Added ROUTES folder in elog. (diff)
downloadgamerlay-52c72083cbcfdec331934e35afa70f46467e550f.tar.gz
gamerlay-52c72083cbcfdec331934e35afa70f46467e550f.tar.bz2
gamerlay-52c72083cbcfdec331934e35afa70f46467e550f.zip
[games-arcade/{rush,tokitori}] Added
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'games-arcade/rush')
-rw-r--r--games-arcade/rush/Manifest1
-rw-r--r--games-arcade/rush/rush-20130703.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/games-arcade/rush/Manifest b/games-arcade/rush/Manifest
new file mode 100644
index 0000000..1c7ff76
--- /dev/null
+++ b/games-arcade/rush/Manifest
@@ -0,0 +1 @@
+DIST RUSH_2013-07-03_Linux_1372878397.sh 230943034 SHA256 eb06a6ac7326692f31ac7087e848b13d5fe7ad45e7dd3dbf564b954bb162a694 SHA512 cee010ddcab62b17cab2ff4229eb271b0908f95623f162f20cb8eef85441f5072ba2bb8a9cbce77a1b215f008b049dbc1b308f6cc3489203fd828fb140a2ba11 WHIRLPOOL 14db5a4cc9c6851f38e5e3a1172de16971d9ccdeaaca35bd602f6b072e94505fa7eaa9a95a88d3434252ff6ba115cac8ce50d2b30113654c0fc844a487554880
diff --git a/games-arcade/rush/rush-20130703.ebuild b/games-arcade/rush/rush-20130703.ebuild
new file mode 100644
index 0000000..0ebf6e0
--- /dev/null
+++ b/games-arcade/rush/rush-20130703.ebuild
@@ -0,0 +1,75 @@
+EAPI="5"
+
+inherit base games unpacker-nixstaller
+# multilib
+
+MY_PN="${PN^^}"
+TS="1372878397"
+MY_P="${MY_PN}_${PV:0:4}-${PV:4:2}-${PV:6:2}_Linux_${TS}"
+
+DESCRIPTION="A simple puzzler that’ll have you mesmerized with a synchronized swarm of brightly colored blocks."
+HOMEPAGE="http://twotribes.com/message/rush/"
+SRC_URI="${MY_P}.sh"
+RESTRICT="fetch"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ media-libs/libsdl:2
+ media-libs/openal
+ sys-libs/zlib
+"
+
+pkg_nofetch() {
+ ewarn
+ ewarn "Place ${A} to ${DISTDIR}"
+ ewarn
+}
+
+S="${WORKDIR}"
+
+DOCS=( "README.linux" )
+
+src_unpack() {
+ local arch=x86
+ use amd64 && arch=x86_64
+ nixstaller_unpack "instarchive_all" "instarchive_all_${arch}"
+}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+ local arch=x86
+ use amd64 && arch=x86_64
+
+ exeinto "${dir}"
+ insinto "${dir}"
+
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}"
+ games_make_wrapper "${PN}" "./${PN}" "${dir}"
+
+ newexe "${MY_PN}.bin.${arch}" "${PN}"
+ newicon "${MY_PN}.png" "${PN}.png"
+
+ doins -r \
+ "namespace.txt" \
+ "audio" \
+ "config" \
+ "default" \
+ "effects" \
+ "cursors" \
+ "fx" \
+ "fonts" \
+ "gameworld" \
+ "guide" \
+ "loc" \
+ "rubiks" \
+ "shared"
+
+ prepgamesdirs
+
+ base_src_install_docs
+}