summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2022-08-16 05:04:22 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2022-08-16 05:05:12 +0300
commit9cacfd47ccdf300fdd81d5e936997fa3a1577715 (patch)
treebe8ffde65bf3002543df11746fce43ee11981640
parentgames-strategy/wyrmsun: update Manifest (diff)
downloadgamerlay-9cacfd47ccdf300fdd81d5e936997fa3a1577715.tar.gz
gamerlay-9cacfd47ccdf300fdd81d5e936997fa3a1577715.tar.bz2
gamerlay-9cacfd47ccdf300fdd81d5e936997fa3a1577715.zip
games-rpg/arx-libertatis: add 1.2.1, drop 1.1.2_p2-r1
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
-rw-r--r--games-rpg/arx-libertatis/Manifest2
-rw-r--r--games-rpg/arx-libertatis/arx-libertatis-1.2.1.ebuild (renamed from games-rpg/arx-libertatis/arx-libertatis-1.1.2_p2-r1.ebuild)18
-rw-r--r--games-rpg/arx-libertatis/files/arx-libertatis-1.1.2-cmake-3.5.patch34
-rw-r--r--games-rpg/arx-libertatis/metadata.xml1
4 files changed, 6 insertions, 49 deletions
diff --git a/games-rpg/arx-libertatis/Manifest b/games-rpg/arx-libertatis/Manifest
index d8d9120..f301aea 100644
--- a/games-rpg/arx-libertatis/Manifest
+++ b/games-rpg/arx-libertatis/Manifest
@@ -1 +1 @@
-DIST arx-libertatis-1.1.2_p2.tar.gz 1289955 SHA256 adcf960bf6ab27f5339d4ed54d38181816a2c215cc969c7a55cfe56212708cef SHA512 b4b462ce707aea835b1cec0f623eb411a4bc5888a7dcd5d9ef0b5cf083145f89d4d8b325a6d47534bb086217fd18114c176501f1d0960e5e277f7ae5140d779b WHIRLPOOL 34170560486651f0747435e70e453109fc48dacebff91dfa5b25c9a2492e0ef8d84c34aa6914400687545ff58e0152a1d2517996915de025945894a81da90e17
+DIST arx-libertatis-1.2.1.tar.xz 2479764 BLAKE2B 4a58d0b06f4aa90ad09cceebbb38cdc2cef20a049fee916311387b5c2493b66cf5c5d683cc704593ca3888172d2e315a7a8cb305350b0c044129348583350911 SHA512 1013b18bb695e99145b44afd012a072cb4f376030301fe4432e503190c45d26f2a4ab0b6ff4ba284bfd10e66007ac8de417f07141e686a56314413c2de35feb4
diff --git a/games-rpg/arx-libertatis/arx-libertatis-1.1.2_p2-r1.ebuild b/games-rpg/arx-libertatis/arx-libertatis-1.2.1.ebuild
index d828706..52ee815 100644
--- a/games-rpg/arx-libertatis/arx-libertatis-1.1.2_p2-r1.ebuild
+++ b/games-rpg/arx-libertatis/arx-libertatis-1.2.1.ebuild
@@ -6,20 +6,20 @@ EAPI=7
CMAKE_WARN_UNUSED_CLI=yes
inherit cmake
-MY_PV=${PV/_p/-r}
-
DESCRIPTION="Cross-platform port of Arx Fatalis, a first-person role-playing game"
HOMEPAGE="https://arx-libertatis.org/"
-SRC_URI="https://github.com/arx/ArxLibertatis/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/arx/ArxLibertatis/releases/download/${PV}/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+c++11 crash-reporter debug static tools +unity-build"
+IUSE="crash-reporter debug static tools +unity-build"
COMMON_DEPEND="
media-libs/freetype
- media-libs/libsdl[X,video,opengl]
+ media-libs/glm
+ media-libs/libepoxy
+ media-libs/libsdl2[X,video,opengl]
media-libs/openal
sys-libs/zlib:=
virtual/opengl
@@ -39,14 +39,8 @@ BDEPEND="virtual/pkgconfig"
DOCS=( README.md AUTHORS CHANGELOG )
-PATCHES=( "${FILESDIR}/${PN}-1.1.2-cmake-3.5.patch" )
-
-S="${WORKDIR}/ArxLibertatis-${MY_PV}"
-
src_configure() {
- # editor does not build
local mycmakeargs=(
- -DBUILD_EDITOR=OFF
-DBUILD_TOOLS=$(usex tools)
-DDEBUG=$(usex debug)
-DICONDIR=/usr/share/icons/hicolor/128x128/apps
@@ -54,11 +48,9 @@ src_configure() {
-DSET_OPTIMIZATION_FLAGS=OFF
-DSTRICT_USE=ON
-DUNITY_BUILD=$(usex unity-build)
- -DUSE_CXX11=$(usex c++11)
-DUSE_NATIVE_FS=ON
-DUSE_OPENAL=ON
-DUSE_OPENGL=ON
- -DUSE_SDL=ON
-DBUILD_CRASHREPORTER=$(usex crash-reporter)
$(usex crash-reporter "-DUSE_QT5=ON" "")
-DUSE_STATIC_LIBS=$(usex static)
diff --git a/games-rpg/arx-libertatis/files/arx-libertatis-1.1.2-cmake-3.5.patch b/games-rpg/arx-libertatis/files/arx-libertatis-1.1.2-cmake-3.5.patch
deleted file mode 100644
index d085afa..0000000
--- a/games-rpg/arx-libertatis/files/arx-libertatis-1.1.2-cmake-3.5.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From c4262bc600dc01d3ddbacc7811132b29ea46ad3b Mon Sep 17 00:00:00 2001
-From: Daniel Scharrer <daniel@constexpr.org>
-Date: Thu, 24 Mar 2016 22:47:44 +0100
-Subject: [PATCH] CMake: Disable variable expansion for quoted strings in if()
-
-This makes the build system more robust against stray variables
-coming from included CMake scripts provided by the system.
-
-Fixes build with CMake 3.5.
-
-This has been fixed in master with commit 60e43c.
----
- CMakeLists.txt | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 93f1ee3..8347544 100755
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -13,6 +13,11 @@ else()
- cmake_minimum_required(VERSION 2.8)
- endif()
-
-+if(POLICY CMP0054)
-+ # CMake 3.1+: Only interpret if() arguments as variables or keywords when unquoted.
-+ cmake_policy(SET CMP0054 NEW)
-+endif()
-+
-
- # Define configuration options
-
---
-2.7.4
-
diff --git a/games-rpg/arx-libertatis/metadata.xml b/games-rpg/arx-libertatis/metadata.xml
index 8a7355e..3d1bf51 100644
--- a/games-rpg/arx-libertatis/metadata.xml
+++ b/games-rpg/arx-libertatis/metadata.xml
@@ -50,6 +50,5 @@
<doc lang="en">http://wiki.arx-libertatis.org/</doc>
<remote-id type="github">arx/ArxLibertatis</remote-id>
<remote-id type="sourceforge">arx</remote-id>
- <remote-id type="freecode">arx-libertatis</remote-id>
</upstream>
</pkgmetadata>