aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEthan Sommer <e5ten.arch@gmail.com>2020-04-21 14:31:49 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-04-22 18:04:20 -0400
commit79f7650b59c4f9261b5e9e76e3c57cfc90b2dc6b (patch)
treef7457ebc9c2b2dbb841c0b53dc0377c08821e23a
parentrules/64-btrfs.rules: Expand @bindir@ to the absolute directory name. (diff)
downloadeudev-79f7650b59c4f9261b5e9e76e3c57cfc90b2dc6b.tar.gz
eudev-79f7650b59c4f9261b5e9e76e3c57cfc90b2dc6b.tar.bz2
eudev-79f7650b59c4f9261b5e9e76e3c57cfc90b2dc6b.zip
switch make usage to be POSIX compatible
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--rules/Makefile.am7
-rw-r--r--src/libudev/Makefile.am19
-rw-r--r--src/udev/Makefile.am13
-rw-r--r--test/Makefile.am2
4 files changed, 20 insertions, 21 deletions
diff --git a/rules/Makefile.am b/rules/Makefile.am
index 6143851a9..96895ff8f 100644
--- a/rules/Makefile.am
+++ b/rules/Makefile.am
@@ -3,6 +3,9 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
EXTRA_DIST = \
64-btrfs.rules.in
+CLEANFILES = \
+ 64-btrfs.rules
+
dist_udevrules_DATA = \
50-udev-default.rules \
60-block.rules \
@@ -46,8 +49,8 @@ endif
do_subst = $(SED) \
-e 's,[@]bindir[@],$(bindir),g'
-64-btrfs.rules: 64-btrfs.rules.in Makefile
- $(do_subst) < $< > $@
+64-btrfs.rules: $(srcdir)/64-btrfs.rules.in Makefile
+ $(do_subst) $(srcdir)/64-btrfs.rules.in > 64-btrfs.rules
install-data-local:
$(MKDIR_P) $(DESTDIR)$(udevconfdir)/rules.d
diff --git a/src/libudev/Makefile.am b/src/libudev/Makefile.am
index 0edb8732d..d069956b3 100644
--- a/src/libudev/Makefile.am
+++ b/src/libudev/Makefile.am
@@ -4,16 +4,6 @@ LIBUDEV_CURRENT=7
LIBUDEV_REVISION=3
LIBUDEV_AGE=6
-define move-to-rootlibdir
- if test "$(libdir)" != "$(rootlibdir)"; then \
- $(MKDIR_P) $(DESTDIR)$(rootlibdir) && \
- so_img_name=$$(readlink $(DESTDIR)$(libdir)/$$libname) && \
- so_img_rel_target_prefix=$$(echo $(libdir) | sed 's,\(^/\|\)[^/][^/]*,..,g') && \
- $(LN_S) -f $$so_img_rel_target_prefix$(rootlibdir)/$$so_img_name $(DESTDIR)$(libdir)/$$libname && \
- mv $(DESTDIR)$(libdir)/$$libname.* $(DESTDIR)$(rootlibdir); \
- fi
-endef
-
AM_CPPFLAGS = \
-include $(top_builddir)/config.h \
-DUDEV_ROOT_RUN=\"$(rootrundir)\" \
@@ -80,7 +70,14 @@ CLEANFILES = \
libudev.pc
install-exec-hook:
- libname=libudev.so && $(move-to-rootlibdir)
+ libname=libudev.so; if test "$(libdir)" != "$(rootlibdir)"; then \
+ $(MKDIR_P) $(DESTDIR)$(rootlibdir) && \
+ so_img_name=$$(readlink $(DESTDIR)$(libdir)/$$libname) && \
+ so_img_rel_target_prefix=$$(echo $(libdir) | sed 's,\(^/\)\?[^/]\+,..,g') && \
+ $(LN_S) -f $$so_img_rel_target_prefix$(rootlibdir)/$$so_img_name $(DESTDIR)$(libdir)/$$libname && \
+ mv $(DESTDIR)$(libdir)/$$libname.* $(DESTDIR)$(rootlibdir); \
+ fi
+
uninstall-hook:
rm -f $(DESTDIR)$(rootlibdir)/libudev.so*
diff --git a/src/udev/Makefile.am b/src/udev/Makefile.am
index 401af01c9..9b4917ad9 100644
--- a/src/udev/Makefile.am
+++ b/src/udev/Makefile.am
@@ -113,17 +113,17 @@ nodist_libudev_core_la_SOURCES = \
keyboard-keys-to-name.h
keyboard-keys.txt: Makefile
- $(AM_V_at)$(MKDIR_P) $(dir $@)
+ $(AM_V_at)f="$@"; case $$f in */*) $(MKDIR_P) "$${f%/*}"; esac
$(AM_V_GEN)$(CPP) $(CFLAGS) $(AM_CPPFLAGS) $(CPPFLAGS) -dM -include linux/input.h - < /dev/null | $(AWK) '/^#define[ \t]+KEY_[^ ]+[ \t]+[0-9]/ { if ($$2 != "KEY_MAX") { print $$2 } }' | sed 's/^KEY_COFFEE$$/KEY_SCREENLOCK/' > $@
keyboard-keys-from-name.gperf: keyboard-keys.txt Makefile
- $(AM_V_GEN)$(AWK) 'BEGIN{ print "struct key { const char* name; unsigned short id; };"; print "%null-strings"; print "%%";} { print tolower(substr($$1 ,5)) ", " $$1 }' < $< > $@
+ $(AM_V_GEN)$(AWK) 'BEGIN{ print "struct key { const char* name; unsigned short id; };"; print "%null-strings"; print "%%";} { print tolower(substr($$1 ,5)) ", " $$1 }' keyboard-keys.txt > $@
keyboard-keys-from-name.h: keyboard-keys-from-name.gperf Makefile
- $(AM_V_GPERF)$(GPERF) -L ANSI-C -t -N keyboard_lookup_key -H hash_key_name -p -C < $< > $@
+ $(AM_V_GPERF)$(GPERF) -L ANSI-C -t -N keyboard_lookup_key -H hash_key_name -p -C < keyboard-keys-from-name.gperf > $@
keyboard-keys-to-name.h: keyboard-keys.txt Makefile
- $(AM_V_GEN)$(AWK) 'BEGIN{ print "const char* const key_names[KEY_CNT] = { "} { print "[" $$1 "] = \"" $$1 "\"," } END{print "};"}' < $< > $@
+ $(AM_V_GEN)$(AWK) 'BEGIN{ print "const char* const key_names[KEY_CNT] = { "} { print "[" $$1 "] = \"" $$1 "\"," } END{print "};"}' keyboard-keys.txt > $@
BUILT_SOURCES = \
@@ -136,9 +136,8 @@ CLEANFILES += \
# install udevadm symlink in sbindir
install-exec-hook:
- if test "$(bindir)" != "$(sbindir)"; then \
- $(LN_S) -n -f $(bindir)/udevadm $(DESTDIR)$(sbindir)/udevadm; \
- fi
+ test "$(bindir)" = "$(sbindir)" || \
+ $(LN_S) -n -f $(bindir)/udevadm $(DESTDIR)$(sbindir)/udevadm
uninstall-hook:
rm -Rf $(DESTDIR)$(sbindir)/udevadm
diff --git a/test/Makefile.am b/test/Makefile.am
index 6d9c77624..b24fda9b4 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -50,7 +50,7 @@ check_DATA = \
test/sys
test/sys:
- $(AM_V_at)$(MKDIR_P) $(dir $@)
+ $(AM_V_at)f="$@"; $(MKDIR_P) "$${f%/*}"
$(AM_V_GEN)tar -C $(top_builddir)/test/test -xJf $(top_srcdir)/test/sys.tar.xz
test-sys-distclean: