aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-05-11 19:04:20 +0200
committerUlrich Müller <ulm@gentoo.org>2023-05-11 19:04:20 +0200
commitad863d288f29bcca776369dec7765dbb0174ba82 (patch)
tree30f79a3b094fa5a28967949e1ddbfeffaa156beb /configure.ac
parentDon't substitute PORTAGEQ in libs (diff)
downloadeselect-ad863d288f29bcca776369dec7765dbb0174ba82.tar.gz
eselect-ad863d288f29bcca776369dec7765dbb0174ba82.tar.bz2
eselect-ad863d288f29bcca776369dec7765dbb0174ba82.zip
Don't autodetect bash and env-update at configure time
* bin/eselect.in: Update shebang to use EPREFIX. Bug 905934. * bin/Makefile.am (dosed): Don't substitute BASH. * libs/package-manager.bash.in (env_update): Don't use an absolute path for env-update. * libs/Makefile.am (dosed): Don't substitute ENV_UPDATE. * configure.ac: Drop checks for bash and env-update paths. Bug: https://bugs.gentoo.org/905934 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index e767884..3d5741b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,15 +8,6 @@ test x$prefix = xNONE && prefix="$ac_default_prefix"
test x$datadir = xNONE && datadir="$ac_default_datadir"
test x$sysconfdir = xNONE && sysconfdir="$ac_default_sysconfdir"
-# BASH may already be set in the shell, if the admin then changes the
-# the /bin/sh symlink to a non-bash shell, all hell will break lose.
-# thanks to James Rowe for the heads up.
-unset BASH
-AC_PATH_PROGS(BASH, bash)
-if test x$BASH = x; then
- AC_MSG_ERROR([bash is required])
-fi
-
# AC_PROG_SED doesn't work here, because on Gentoo FreeBSD systems it
# is confused by a wrapper script that is in the PATH at build time.
AC_CHECK_PROGS(SED, [gsed sed])
@@ -31,9 +22,6 @@ else
AC_MSG_ERROR([GNU sed is required])
fi
-AC_PATH_PROG(ENV_UPDATE, env-update, /usr/sbin/env-update,
- [$PATH:$prefix/sbin:/usr/sbin])
-
CANONICALISE=""
# realpath is included with Coreutils since version 8.15 (2012)
AC_CHECK_PROGS(REALPATH, [grealpath realpath])